-   Linux - Software (
-   -   When I run rpm -Uvh it says "warning: waiting for transaction lock" (

Niceman2005 11-12-2004 02:35 AM

When I run rpm -Uvh it says "warning: waiting for transaction lock"
Hi all,

Not sure for what reason that when I tried to install rpm files the following output came out:

# rpm -Uvh squid-1.1.21-1.i386.rpm
warning: waiting for transaction lock

and it just stay there till I break it with ctrl + c and it displayed:

error: can't create transaction lock

I am using fedora 3.0

Thanks all for helping,

acid_kewpie 11-12-2004 03:14 AM

sounds like rpm crashed or was incorrectly aborted on an earlier installation there will be a lock file on the rpm database in /var/lib/rpm/somewhere.... but i'm not sure where, as i've not touched rpm's for years now... it should be pretty obvious, and if you this you've found it, move it to a temp location, and try installing again. if that works, delete that lock file.

henryg 11-12-2004 07:11 AM

rm /var/lib/rpm/RPMLOCK

acid_kewpie 11-12-2004 07:16 AM

yeah i'd say that technically classes as "obvious"! :D

borrrden 11-12-2004 07:10 PM

I've only ever gotten that error when I forgot to be root before I installed an RPM :-D

Niceman2005 11-12-2004 07:47 PM

Hello acid_kewpie, henryg and borrden

Thank you very much for helping.

Yeah, I got that transaction lock thingi fixed. Like you suggested I searched for the lock file. The name of the lock file is " rpmdb_deadlock", after I removed that, RPM installation was perfect.

Once again, thank you very much!

All times are GMT -5. The time now is 09:41 AM.