LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   When booting su: /bin/bash: Permission Denied (https://www.linuxquestions.org/questions/linux-software-2/when-booting-su-bin-bash-permission-denied-474056/)

Kalimdora 08-15-2006 09:56 AM

When booting su: /bin/bash: Permission Denied
 
:scratch:
Hi, I have a serious problem, after upgrade my Fedora C2 to FC4 my startup script give me an error. I can't find the solution so I decided to ask your experience....


My script like "su - root -m -c /home/mydir/myscipt"

before upgrade fc4, there was no problem... bu after FC4, when the systen starting up, gives me en error about bash permission and about my script...

Error:

su: /bin/bash: Permission Denied.

Do you have an experience about this problem... My java program must be start with root permission...

When I run the script from shell manual, there is no problem again.. service starts welll....

So what is the problem and how can I solve it, please help me!!!

Kalimdora 08-15-2006 10:04 AM

I found the solution... Everything about SELinux... After I set enforcing to off, the problem solved....


Thanks everybody... It was very quick :)


All times are GMT -5. The time now is 02:27 PM.