LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   what rpms missing for # ./configure (https://www.linuxquestions.org/questions/linux-software-2/what-rpms-missing-for-configure-4175588894/)

Glenn D. 09-06-2016 10:28 PM

what rpms missing for # ./configure
 
What is missing ?
--Glenn

-installed rpms
# rpm -qa | grep -i libaal |sort
libaal-1_0-6-1.0.6-106.1.x86_64
libaal-devel-1.0.6-106.1.x86_64
libaal-minimal0-1.0.6-106.1.x86_64

# ./configure
.
.
checking for time... yes
checking for uname... yes
checking for sysconf... yes
checking whether -falign-loops works... yes
checking whether -Wuninitialized works... yes
checking whether -Wno-unused-parameter works... yes
checking whether -Wredundant-decls works... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
configure: WARNING: Can't detect right _FILE_OFFSET_BITS. Will be forced to 64bit.
checking size of off_t... 8
checking for aal_device_open in -laal... yes
checking aal/libaal.h usability... yes
checking aal/libaal.h presence... yes
checking for aal/libaal.h... yes
checking for libaal version = 1.0.6... no

##
# cat ./configure |grep -i libaal
with_libaal
--with-libaal prefix of where libaal was installed
# Macro for checking libaal
# Check whether --with-libaal was given.
if test "${with_libaal+set}" = set; then :
withval=$with_libaal;
if test x$with_libaal != x; then
LIBS="-L$with_libaal/lib"
LDFLAGS="$LDFLAGS -L$with_libaal/lib"
CFLAGS="$CFLAGS -I$with_libaal/include"
CPPFLAGS="-I$with_libaal/include"
#define HAVE_LIBAAL 1
as_fn_error $? "libaal not found; install libaal available at \
ac_fn_c_check_header_mongrel "$LINENO" "aal/libaal.h" "ac_cv_header_aal_libaal_h" "$ac_includes_default"
if test "x$ac_cv_header_aal_libaal_h" = xyes; then :
as_fn_error $? "<aal/libaal.h> not found" "$LINENO" 5
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libaal version = 1.0.6" >&5
$as_echo_n "checking for libaal version = 1.0.6... " >&6; }
char libaal_version ();
return libaal_version ();
as_fn_error $? "libaal can't execute test" "$LINENO" 5
libaal_config_major_version=`echo 1.0.6 | \
libaal_config_minor_version=`echo 1.0.6 | \
libaal_config_micro_version=`echo 1.0.6 | \
# Compare MINIMUM-VERSION with libaal version
#include <aal/libaal.h>
if (!(version = libaal_version()))
if ((major >= $libaal_config_major_version) &&
((major == $libaal_config_major_version) &&
(minor >= $libaal_config_minor_version)) &&
((major == $libaal_config_major_version) &&
(minor == $libaal_config_minor_version) &&
(micro >= $libaal_config_micro_version)))
printf("\nAn old version of libaal (%s) was found.\n",
printf("You need a libaal of the version %d.%d.%d or newer.\n",
$libaal_config_major_version, $libaal_config_minor_version,
$libaal_config_micro_version);
#define HAVE_LIBAAL_MINIMAL 1
as_fn_error $? "libaal-minimal not found; install libaal available at \
ac_fn_c_check_header_mongrel "$LINENO" "aal/libaal.h" "ac_cv_header_aal_libaal_h" "$ac_includes_default"
if test "x$ac_cv_header_aal_libaal_h" = xyes; then :
as_fn_error $? "<aal/libaal.h> not found" "$LINENO" 5
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libaal-minimal version = 1.0.6" >&5
$as_echo_n "checking for libaal-minimal version = 1.0.6... " >&6; }
char libaal_version ();
return libaal_version ();
as_fn_error $? "libaal-minimal can't execute test" "$LINENO" 5
libaal_config_major_version=`echo 1.0.6 | \
libaal_config_minor_version=`echo 1.0.6 | \
libaal_config_micro_version=`echo 1.0.6 | \
# Compare MINIMUM-VERSION with libaal version
#include <aal/libaal.h>
if (!(version = libaal_version()))
if ((major >= $libaal_config_major_version) &&
((major == $libaal_config_major_version) &&
(minor >= $libaal_config_minor_version)) &&
((major == $libaal_config_major_version) &&
(minor == $libaal_config_minor_version) &&
(micro >= $libaal_config_micro_version)))
printf("\nAn old version of libaal (%s) was found.\n",
printf("You need a libaal of the version %d.%d.%d or newer.\n",
$libaal_config_major_version, $libaal_config_minor_version,
$libaal_config_micro_version);

dijetlo 09-07-2016 09:49 AM

Quote:

# rpm -qa | grep -i libaal |sort
libaal-1_0-6-1.0.6-106.1.x86_64
libaal-devel-1.0.6-106.1.x86_64
libaal-minimal0-1.0.6-106.1.x86_64
....
checking for libaal version = 1.0.6... no
Configure doesn't appear to know the path to your libaal installation, perhaps a "libdirs" switch?

John VV 09-07-2016 03:46 PM

what is this UNKNOWN program you are building ?
was it for a 32 bit system ?
is there any autotools and m4 macros ?
is there a "autoconf.sh" ?
you might need to remake "configure" for a 64 bit system

but without any of the needed information ???????
i can only GUESS


All times are GMT -5. The time now is 05:29 AM.