-   Linux - Software (
-   -   What is wrong when I use EasyBCD 1.6 to boot FC7? (

martinr 08-29-2007 03:40 PM

What is wrong when I use EasyBCD 1.6 to boot FC7?

I have Vista (please forgive me) installed on the primare master. Vista was installed first. I have installed Fedora 7 on the secondary slave. Partitioning of the linux-drive is standard settings. The bootloader is grub, which I installed to the /boot partition. It is instructed only to boot Fedora and not to care about any other partition.

Using EasyBCD 1.6 in Vista I added the linux partition to the Windows bootloader.

After reboot Fedora shows up as an alternative. But When I choose it every thing that happens is:

loading new partition
Bootsector from C.H. Hochstätter

And then nothing!

Is there something wrong with the configuration of grub or is there some sort of disk error? Or what could it be?

The linux drive is an IDE, set as a secondary slave. The Vista drive is a SATA drive.

Very thankful for assistance,

syg00 08-29-2007 04:53 PM

I've done similar with Ubuntu - the procedure you followed seems fine.
I'd say Anaconda needs some serious work for multi disk installs.

Use the Fedora CD to boot into the (hard) disk install and try re-installing grub (to the partition). You shouldn't need to redo the BCD work.

martinr 08-30-2007 05:44 AM


When I boot with the rescue CD and choose "boot from this disk" or something simiar the only things that reads is "PRESS ANY KEY TO REBOOT" and then, obviously, nothing new happens.

When I choose "rescue this system", then it appears that it wants to redo the installation, so that's probably the wrong alternative. How do you use the rescue to correctly boot into fedora? Should you add some special command? where in that case?

One funny thing that I couldn't really understand is if there is one MBR for each disk? Again, I did not intall grub to the mbr, but when the option was shown it read "install mbr to /sdb/" ? /sdb is the linux disk. /sda is the SATA Vista disk.
Had I done that It would mean that I would have one MBR on each disk, right? How does that work?


Computer Guru 08-30-2007 09:05 AM

You can take a look at the EasyBCD documentation at to get it to work, if you like.

1) Install GRUB to the bootsector (of the partition), and not the MBR of the hard drive.
2) Point EasyBCD to that partition and add a Linux entry. All done.

If you want a more pain-free route:

1) Grab EasyBCD 1.61 beta.
2) Add a Linux entry and check the "GRUB isn't installed to the bootsector" option; then add.

If you opt to use the latter route, EasyBCD will search for the FC7 menu.lst file, and load it at boot time to boot into FC7 without needing to install GRUB to the bootsector.

Hope this helps!

NeoSmart Technologies

martinr 08-30-2007 09:27 AM

I did read the guide before trying, and it seemed so very easy. Sadly it didn't work. I'll try the beta version a.s.a.p. and let whomever reading this know if it worked.

nan0meter 08-30-2007 09:51 AM

I don't know anything about EBCD but it might be useful for people who do know about it to know how you configured your grub (/boot/grub/menu.lst ?). Please post its contents here if you like, it would be useful i guess.

martinr 08-30-2007 12:41 PM

Hi again,

Now I've installed and tried the new beta version of EasyBCD. I added two new entries to the bootloader. first one that is told to use grub and then one where it's told not to use grub.

with grub this happens:
Bootpart 2.60 Bootsector (C) blah blah...
Loading new partition

And then it freezes.

For the one without grub:
I end up i a grub(!!!) terminal, where I can press TAB to get a long list of command which I don't know how to use. It's not the usual grub menu. Just a black screen saying GRUB: (and some short instructions at the top)

When I use the rescue disk to get to a terminal it sais it mounts the linux partition on /mnt/sysimage. I can't seem to find the /boot partition anywhere though. And I don't know how to find the grub.conf file to check that one out.

I hope you have patience enough to help me,

Computer Guru 08-31-2007 04:54 AM

Sounds like your GRUB is damaged/not installed correctly.

Boot from a Linux Live CD/DVD and reinstall GRUB according to the instructions at

martinr 09-02-2007 12:01 PM

This still isn't working.

I have reinstalled linux just to make sure that there were no errors in the partitioning. I haven't tried supergrub yet (due to a faulty CD), But I can acces grub.conf via the rescuemode. There it sais that the partition used is hd0,0 ... this should be hd1,0 right? (I have Vista installed on hda) How can I check what should be written here?

When I look in EasyBCD i choose Grub, and drive1. In drive one there are two partitions.

partition 0 - linux native - 0GB (which I guess the /boot is on?)


partition 1 - ????? - 38GB (This would be the extended partition, why does it say "?????" ? )

Also could there possibly be any error with how my harddrive is set (with the physical pins on its back, It should be set as a secondary slave. Should I change it to a primary master or cable select or something?)

Thanks again for the help,

martinr 09-02-2007 12:22 PM

In rescuemode I looked in the /etc/fstab to see where stuff were mounted. And I honestly can't get this. What should I really write here?

/ ext3 default 1 1
/boot ext3 default 1 2
/dev/shm 0 0
/dev 0 0

and so on...

In EasyBVD, When I use the "neogrub" option I get to a wroking grub termnal saying: grub>

When I try the option of finding grub on partition 1 (drive 1) then I get to something like: GRUB (and I think this one is frozen)

should I edit menu.1st (or however it's spelled), or grub.conf and what do I write there?

getting tired...

martinr 09-05-2007 03:41 PM

Anyone, please?

If I can check on which partition (hdx,y) that grub is located on I guess configuring it via the rescue mode will fix the problem? is there a command I can run from the linux console that tells me?

syg00 09-05-2007 11:34 PM

Can you get hold of a decent liveCD ???. Knoppix or somesuch - even PcLinuxOS (or whatever it's called).
If you have DHCP that should get you connected. From a terminal let's see "fdisk -l" (might need root).

martinr 10-27-2007 12:38 PM

Hi everyone, I finally figured it out. For some reason GRUB was wrongly configured from the beginning (WHY?!?!)

It was fixed by starting fedora rescue mode and going to /boot/grub and entering the following

root (hd1,0)
setup (hd1,0)
setup (hd1,0)


where hd1,0 is the boot partition of my linux system. For some reason it was set up to hd0,0

All times are GMT -5. The time now is 12:54 PM.