LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   What does this KDE / KPDF message mean? (https://www.linuxquestions.org/questions/linux-software-2/what-does-this-kde-kpdf-message-mean-466629/)

MBA Whore 07-22-2006 06:59 PM

What does this KDE / KPDF message mean?
 
Warning - KWin

Window with title "KPDF" is not responding. This window belongs to application kpdf (PID=5101, hostname=localhost).
Do you wish to terminate this application? (All unsaved data in this application will be lost.)


I got that message everytime I tried to open a PDF under Linux (MEPIS 3.43, KDE 3.52). Strangely, I never had this problem before with that PDF or any other PDF. Now suddenly it is acting up. So, I went online where I found that PDF, downloaded it again, and now all is well. In other words, I downloaded the exact same PDF and I can open it fine, but the original PDF download still throws a fit (but it never did before).

If it helps any, I did notice a slight file size difference between the 2 downloads.

I am stumped. Shi@t like this, though small and annoying, makes me want to go back to Windows. Should I see if Windows has the same trouble opening the 2 PDFs in question?

Thanks, I look forward to your replies!

jonaskoelker 07-22-2006 08:21 PM

It sounds very much like you had a bad download.

try running a couple of things:
Code:

$ file old.pdf
$ xpdf old.pdf
$ gpdf old.pdf
$ pdf2ps old.pdf
$ gv old.ps
$ ggv old.ps
$ some-kde-postscript-viewer old.ps
$ cmp old.pdf new.pdf

If cmp says EOF, it means that the files are identical in the first N bytes, where N = minimum(sizeof old.pdf, sizeof new.pdf). Which would indicate an aborted download. Try looking at wget's resume download facility. Can you resume the download of the broken pdf?

In addition to the things I have suggested above, feel free to test out your favorite pdf viewers on windows as well.

I hope this enlightens you (a bit).

MBA Whore 07-23-2006 12:33 AM

It did it in Windows too
 
I tried it in Windows too...same thing. The original file (i.e., the 1st download) did not open, but the 2nd file (i.e., the 2nd download) did open.

Strange. Anyways, thanks for your thoughts. I was thinking that it might have been a bad download myself...now I am certain that is the case.


All times are GMT -5. The time now is 02:20 AM.