LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   wget problem - spaning domains (https://www.linuxquestions.org/questions/linux-software-2/wget-problem-spaning-domains-147299/)

MarlaSinger 02-17-2004 03:47 PM

wget problem - spaning domains
 
Hello together,

I have a persisten problem understanding GNU wget Vers. 1.8.2 - even after I've rtfm-ed the man pages ten times (at least).

Say, I want to download from a site recursivlely (up to 5 levesl) and no partent directories and for local viewing, o.k., then I write:
wget -r -l5 -np -k -E -p U-R-L

Where [U-R-L] is a fully qualified H-T-T-P Path to a file on the web (sorry, I'm not allowed to post real URLs here)

No problem so far. The "-p" switch schould cause wget to download all stylesheet and img-Tag references locally. Well, but it doesn't! If for example, there is an image tag with src= "[otherU-R-L]" - then the image is *not* loaded. otherURL is an completeley different domain than U-R-L

What to do?

Greetings
Marla

zerodice 03-05-2004 07:29 PM

yeah i ran into the same problem, when i transfered servers.
when i ran wget it just would take the .html files. I tared up my
site and transfered it that way. I have also looked through the
man pages and with no luck could find how to grab an entire
site with the correct directorys.


All times are GMT -5. The time now is 10:10 AM.