-   Linux - Software (
-   -   wget & Slack patches (

revenant 03-27-2004 11:57 AM

wget & Slack patches
I have just installed Slackware 9.1 and I'm trying to download the latest security patches. I tried to used the following command to download all the *.tgz files in the directory.


Then I get the following output and error message.

=> `.listing'
Resolving done.
Connecting to[]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/slackware/slackware-9.1/patches/packages ... done.
==> PORT ... done. ==> LIST ...
Error in server response, closing control connection.

Is there something I'm doing wrong? Any suggestions on a better a better way?

Any help would be appreciated.

trickykid 03-27-2004 12:09 PM

You can't use * in the address field.

man wget for more options of getting all files out of a directory, etc.

skelly 08-30-2004 12:53 PM

.. sure it supports wild cards. Take this excerpt directly from the manpage:


-g on/off

Turn FTP globbing on or off. Globbing means you may use the shell-like special characters (wildcards), like *, ?, [ and ] to retrieve more than one file from the same directory at once, like:


By default, globbing will be turned on if the URL contains a globbing character. This option may be used to turn globbing on or off permanently.

You may have to quote the URL to protect it from being expanded by your shell. Globbing makes Wget look for a directory listing, which is system-specific. This is why it currently works only with Unix FTP servers (and the ones emulating Unix ls output).
You might want to try --glob=on to explicitly enable it and also try quoting the path as suggested to ensure that your shell isn't expanding the wildcard before it gets to wget.

I realized this is a significantly late response, but it never hurts to set things straight. I found this post on a search because I'm getting the same error message but from a different cause.

All times are GMT -5. The time now is 05:32 AM.