LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-08-2014, 12:59 PM   #1
Hungry ghost
Senior Member
 
Registered: Dec 2004
Posts: 1,222

Rep: Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667
Weird volume-control behaviour after installing pulseaudio


Hi guys,

Two or three weeks ago I installed pulseaudio on my Debian Sid install so the new version of Skype would work. After installing it I started noticing weird sound issues. For instance, sometimes I'm playing a song on Amarok at about 35% volume and all of a sudden the next song starts playing at 100% volume, which is very inconvenient since I regularly use earphones. I'm not sure about this, but it seems to me this tends to happen when I play a song after watching a video on Youtube.

In addition, I just noticed that the volume control inside Amarok doesn't work at all. It can be set to 0% or to 100% but what the system really obeys to is the KDE mixer sound control (the icon in KDE's dock) as well as the physical volume controls of my laptop (volume up and down and mute).

Not sure whether this is a bug in pulseaudio or some configuration problem with my system. Does anyone have any clues about what's wrong and how to solve it?

BTW, I'm using KDE on Debian Sid as I said before and my version of pulseaudio is 5.0-6. The hardware is a Lenovo G460 laptop with an Intel 5 Series/3400 Series sound card.

Thanks for any help!
 
Old 09-09-2014, 06:31 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
I'm using Debian, KDE (4.14), pulseaudio 5.0-6, amarok 2.8.0 Skype 4.3 and a 3.16-2.dmz.1-liquorix-amd64 kernel. The volume control on amarok works normally. As for skype, I did have trouble with it and pulseaudio (I posted something about that problem somewhere on this site). I got skype to work by changing the command to:
Code:
PULSE_LATENCY_MSEC=60 skype %U
instead of using just "skype %U". I haven't gone back to the simpler command to check to see if the Pulse-latency setting is still necessary. Anyway you can give it a try and see if it helps at all.
jdk
 
Old 09-09-2014, 06:53 AM   #3
Hungry ghost
Senior Member
 
Registered: Dec 2004
Posts: 1,222

Original Poster
Rep: Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667
Hi jdkaye, thanks for your reply.

What was the exact problem you were having with skype? Skype works fine on my system, except for the fact that, when it makes any sound, Amarok stops playing sounds. It's minor, but a bit annoying.

In regards to the first problem I posted in the OP, I tried this, but I still have to test it longer to see if it really works.

I haven't found any useful information regarding the second problem (Amarok's volume control not working). It seems to occur randomly: sometimes it works, sometimes it doesn't, so I'm not sure what can be causing it. In any case, it looks like some sort of interference between pulseaudio and Amarok.

I'll post back if I find a solution.

Cheers!
 
Old 09-09-2014, 08:19 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Sorry I misread your OP. My problem with skype was I wasn't getting any sound on the receiving end. Replacing the command as shown above solved that problem. Someone else had had a similar problem. I don't think I've ever tried using amarok while skype was open. I'll experiment and see if mine does the same although I can't think of why I would have amarok playing while I was using skype. I normally use a headset for audio. I'll report back on my test.
jdk
edit: I was playing a track on amarok and then started up skype and dialed the test call number. As soon as it started ringing the number amarok's sound cut out. Is this what you were talking about? It seems more like a feature than a bug, i.e. intentional.
jdk

Last edited by jdkaye; 09-09-2014 at 08:24 AM.
 
1 members found this post helpful.
Old 09-09-2014, 09:15 AM   #5
Hungry ghost
Senior Member
 
Registered: Dec 2004
Posts: 1,222

Original Poster
Rep: Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667
Quote:
Originally Posted by jdkaye View Post
I was playing a track on amarok and then started up skype and dialed the test call number. As soon as it started ringing the number amarok's sound cut out. Is this what you were talking about? It seems more like a feature than a bug, i.e. intentional.
Yes, that's what I meant. Regarding why using Skype while Amarok is running, sometimes I'm just playing music on Amarok and browsing the web with Skype open on the background waiting for someone to connect. If someone gets online, the notification sound Skype plays, makes Amarok stop playing for a few seconds (the same goes for the sound Skype plays when I get online). It's a minor issue, but it's still a bit annoying.
 
Old 09-09-2014, 11:28 AM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
I see. I have slightly different behaviour. As long as skype is on but in waiting-for-a-call mode, amarok behaves normally. When I make a call (as in calling the test number) then it cuts out at once. I'll try to have amarok running when I'm expecting a skype call (I don't use skype that much) and see if I get the same result as you.
jdk
 
1 members found this post helpful.
Old 09-09-2014, 12:56 PM   #7
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Wiesbaden, Germany
Distribution: Arch
Posts: 1,053

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
It's Lennart's fault
 
Old 09-09-2014, 01:20 PM   #8
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,532

Rep: Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322
I'm afraid I don't have Skype on my install to help you -- but I take it you looked for the obvious setting in Skype to mute other programs (honestly, I only mention it in case it skipped anyoneKs mind it might be there and don't expect it is)?
Then, I'm not quite sure how VLC hooks in to Pulse Audio but you might want to make sure it is using Pule Audio and not ALSA as more that one ALSA source, in my experience, tends to cause issues in my experience.
Then you could look at (again, I hope not too obvious) pavucontrol "Pulse Audio Volume Control" to see whether it mutes VLC or changes its output sink when you start Skype.
I have never had Pulse Audio working properly on one of my desktop Debian derivative (from Ubuntu at the time PulseAudio first surfaced to Sid now) so, perhaps, it's an incompatibility between PulseAudio and Debian?
 
1 members found this post helpful.
Old 09-10-2014, 06:15 AM   #9
Hungry ghost
Senior Member
 
Registered: Dec 2004
Posts: 1,222

Original Poster
Rep: Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667
Thanks for your answers, guys.

The first problem (Amarok volume jumping to 100% after using another program) seems to be solved, but since it's random, I have to test it for a few days more to be sure.

I haven't managed to solve the second problem (Amarok volume control not working). Funnily, if I stop Amarok, play a video on Youtube and use Amarok again, its volume control do work.

Quote:
Originally Posted by 273 View Post
I'm afraid I don't have Skype on my install to help you -- but I take it you looked for the obvious setting in Skype to mute other programs (honestly, I only mention it in case it skipped anyoneKs mind it might be there and don't expect it is)?
Is there such setting in Skype? I checked the settings but couldn't find it. Do you know exactly where is it?

Quote:
Then, I'm not quite sure how VLC hooks in to Pulse Audio but you might want to make sure it is using Pule Audio and not ALSA as more that one ALSA source, in my experience, tends to cause issues in my experience.
Then you could look at (again, I hope not too obvious) pavucontrol "Pulse Audio Volume Control" to see whether it mutes VLC or changes its output sink when you start Skype. I have never had Pulse Audio working properly on one of my desktop Debian derivative (from Ubuntu at the time PulseAudio first surfaced to Sid now) so, perhaps, it's an incompatibility between PulseAudio and Debian?
I'm using Amarok with VLC as sound engine (actually, it's the sound engine for the entire KDE desktop in my personal setup) and the VLC pulseaudio plugin is installed, so in theory there shouldn't be any issues there. But yes, in my experience pulseaudio equals headaches on Debian; not sure why. I have an openSuse install in this same laptop and have no issues with pulseaudio, amarok and skype.

I tried your suggestion of checking the volume levels on pavucontrol when opening Skype, and Skype indeed mutes Amarok when playing any sound (it's not on launch, but whilst playing sounds, once the login notification stops, Amarok resumes playing sounds).

I'll keep tinkering with this to see if I find any solution and post back my results.

Cheers!
 
Old 09-19-2014, 03:58 PM   #10
Hungry ghost
Senior Member
 
Registered: Dec 2004
Posts: 1,222

Original Poster
Rep: Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667
There's definitely something wrong with pulseaudio on Debian and/or my setup. If I want to use my laptop's built-in speakers after boot, I need to connect the earphones and disconnect them in order to have any sound coming out of the speakers.

In addition, some days ago I was trying to speak to someone on Skype and they told me my voice sounded to low on their side, even though the microphone levels were properly adjusted on my side. I switched to openSUSE, Skyped worked perfectly there (which discards any issue on the PC of the person I was talking to).

I will uninstall Skype and pulseaudio from my Debian install. After all I can use Skype on openSUSE just fine.

Since I couldn't find a real fix, I'm not marking this as solved so as to not mislead other people who may be experiencing the same problem.

Cheers.
 
Old 09-19-2014, 04:04 PM   #11
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,532

Rep: Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322
That's a sad conclusion as it seems to agree with a conclusion I have been coming to that PulseAudio is broken in Debian and isn't likely to be fixed. It seems that, perhaps, it hasn't been PulseAudio that's been buggy all this time but just that the Debian developers don't want to package it properly so that it works?
 
Old 09-19-2014, 04:14 PM   #12
Hungry ghost
Senior Member
 
Registered: Dec 2004
Posts: 1,222

Original Poster
Rep: Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667Reputation: 667
Yeah, I'm not sure exactly what's wrong with the PA implementation on Debian. It has worked intermittently for me with previous versions (some versions worked fine, others didn't). Might be an unfixed bug or a configuration issue; don't know.
 
Old 09-19-2014, 04:23 PM   #13
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,532

Rep: Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322
All I know is that without resorting to making many combinations of changes to configuration files and testing them I'll not even be able to set my default output device. It might just be a Sid thing but I couldn't even install the Pulse Audio graphical configuration tool to set up a simultaneous output device without uninstalling the volume control then reinstalling it when I was done.
Then there's the fact that PulseAudio is usually in my top 5 processes no matter what I'm doing and that sometimes audio is just messed up.
It does work, as in most of the time I can listen to audio and it plays back OK but it's definitely not working properly ofr me and never has.
 
  


Reply

Tags
pulseaudio, sound, volume control


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PulseAudio Volume Control; Connection Failed; Connection Terminated buccaneere Linux - Software 0 01-29-2013 03:44 AM
Problem with maximum audio volume + volume control threshold mensch Debian 6 10-10-2008 11:48 AM
Volume Control: Intel 82801DB-ICH4 (Alsa mixer) won't save volume levels. cayspekko Linux - Newbie 2 01-31-2008 01:17 AM
Error message when launching volume control - no volume rm_-rf_windows Mandriva 9 06-26-2007 01:17 PM
Weird problem with gnome-volume-control hkl8324 Debian 1 01-26-2006 03:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration