LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-17-2009, 07:54 AM   #1
borsaman
LQ Newbie
 
Registered: Mar 2008
Posts: 5

Rep: Reputation: 0
Question webkit compile error on libsoup


Hi all,

I try to compile webkit. One dependency is libsoup. I have installed the v2.4 (suggested it bigger than 2.27.4), but there is an error. The output is like this.

------
checking for LIBSOUP... configure: error: Package requirements (libsoup-2.4 >= 2.27.4) were not met:

Requested 'libsoup-2.4 >= 2.27.4' but version of libsoup is 2.4.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBSOUP_CFLAGS
and LIBSOUP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
------

Can you help me?
 
Old 08-17-2009, 08:27 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,891

Rep: Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883
Well, 2.4 is less than 2.27
I guess you have to d/l and install the latest version from git
Code:
git clone git://git.gnome.org/libsoup
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL Client with libsoup? jasak Programming 2 06-01-2009 11:02 AM
libsoup-2.2.91 compile error mushk45 Slackware 2 03-29-2006 03:13 PM
Dependency problem installing gnomemeeting: libsoup belga Linux - Software 1 07-28-2004 11:47 AM
Evolution in Slack and Libsoup Fuel Slackware 10 02-01-2004 12:43 AM
ximian 1.4 problem > libsoup-2.0.so.0 tentonipete Slackware 2 07-06-2003 05:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration