LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 02-17-2013, 06:03 AM   #1
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Rep: Reputation: Disabled
We can I find nedit binary for IBM POWER server under RHEL 5 or RHEL 6


I have IBM POWER P5 server running RHEL 5.8.
I'm looking for NEDIT editor binary code for this machine.
In nedit.org I found nedit for IBM POWER-AIX and for Intel RHEL.
 
Old 02-17-2013, 08:57 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 13,772

Rep: Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346
Quote:
Originally Posted by vvertsberger View Post
I have IBM POWER P5 server running RHEL 5.8.
I'm looking for NEDIT editor binary code for this machine.
In nedit.org I found nedit for IBM POWER-AIX and for Intel RHEL.
According to RHEL, it's been in the repositories since 2009. Since you're using RHEL, type in "yum install nedit". Since you're paying for RHEL, you have access to the repositories.

Otherwise, why don't you download the source package of nedit and compile it?
 
Old 02-21-2013, 12:56 AM   #3
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Thank you.
yum install nedit resulted with error:
Missing dependency: libXm.so.4 is needed by package nedit-5.5-21.el5.ppc.rpm

and I cannot find package containing libXm.so.4 on the media.
 
Old 02-21-2013, 10:14 AM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 13,772

Rep: Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346
Quote:
Originally Posted by vvertsberger View Post
Thank you.
yum install nedit resulted with error:
Missing dependency: libXm.so.4 is needed by package nedit-5.5-21.el5.ppc.rpm
and I cannot find package containing libXm.so.4 on the media.
Have you contacted Red Hat support, since a package in their yum repository isn't working correctly??? And it could very well be that the particular file(s) you're looking for, aren't in the PPC repository. Again, Red Hat support can help you with this.

And again, why don't you try downloading the source, and compiling it?
 
Old 02-21-2013, 02:37 PM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,067

Rep: Reputation: 1574Reputation: 1574Reputation: 1574Reputation: 1574Reputation: 1574Reputation: 1574Reputation: 1574Reputation: 1574Reputation: 1574Reputation: 1574Reputation: 1574
if you have third party repos installed it is possible that nedit is being grabbed from one of them and not RHN

have a look at
Code:
su -
yum info nedit
to see just where it is being grabbed from

to see just what repos are installed and if they are ON or OFF
Code:
su -
yum repolist all
 
1 members found this post helpful.
Old 02-27-2013, 07:37 AM   #6
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
My machine is IBM server 9110-51A (PowerPC 5) and it is not connected to internet.
I use DVD media that I received from RHEL.
When I cd to /media/RED_HAT/Server directory I see rpm nedit-5.5-21.el5.ppc.rpm
Trying to install it I get error about libXm.so.4
It is difficult to get RHEL binary for PPC64 architecture.
 
Old 02-27-2013, 08:44 AM   #7
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 13,772

Rep: Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346Reputation: 2346
Quote:
Originally Posted by vvertsberger View Post
My machine is IBM server 9110-51A (PowerPC 5) and it is not connected to internet.
I use DVD media that I received from RHEL.
When I cd to /media/RED_HAT/Server directory I see rpm nedit-5.5-21.el5.ppc.rpm
Trying to install it I get error about libXm.so.4
It is difficult to get RHEL binary for PPC64 architecture.
Ok...AGAIN, why don't you download the SOURCE and COMPILE IT????? It will take about five minutes, and you're done. And AGAIN, have you contacted Red Hat support?

Reposting the same question is pointless. You've been given some advice and things to do, and until you actually DO THEM and see what the results are, there's not much reason to post back. Yes, we know you want to install nedit...yes, we know it's giving you a dependency issue. And we've given you TWO WAYS AROUND IT. It's up to you to go try them.
 
Old 03-03-2013, 01:48 AM   #8
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Thank you.
I've got from the RHEL two rpm packages:
openmotif-2.3.1-6.1.el5_8.ppc64.rmp
openmotif-2.3.1-6.1.el5_8.ppc.rpm

I removed two openmotif packages installed before:
yum remove openmotif22-2.2.3-20
yum remove openmotif-2.3.1-6.el5

I installed two received packages:
rpm -ivh openmotif-2.3.1-6.1.el5_8.ppc64.rmp
rpm -ivh openmotif-2.3.1-6.1.el5_8.ppc.rpm

and that eventually solved the problem with dependancies.
Thank you all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Duplicating a RHEL 5.1 32bit server on RHEL 5.4 64 bit wernox Red Hat 1 12-09-2009 02:15 PM
How to find whether my Linux is RHEL ES or RHEL AS? ravikn76 Linux - General 5 03-19-2009 01:20 AM
I am getting bad sector error in RHEL 4 U6 in IBM 3650 server with RAID 8.3. shajahan Linux - Hardware 3 12-02-2008 10:09 PM
RHEL 5 - Dell SC440 Server - shut down only displays ACPI Power Off Called wo2caisley Linux - Newbie 1 05-07-2008 09:13 PM
Login problems with XDMCP from a pre-RHEL-4 client to a RHEL-4 server running KDE cspao Red Hat 0 07-21-2006 06:30 AM


All times are GMT -5. The time now is 12:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration