LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-19-2016, 01:14 PM   #1
harveyslash
LQ Newbie
 
Registered: Nov 2016
Posts: 1

Rep: Reputation: Disabled
Exclamation Wake On lan doesnt work after installing windows


I installed windows on a separate HDD , and now WOL doesnt work over lan, or from the internet( im behind a router, with port 9 forwarded to machine)

I do sudo wakeonlan -i ROUTER IP 00:d4:XX:XX:4f:XX
earlier it used to work , now it doesnt.

I had installed WOL using this :

https://www.cyberciti.biz/tips/linux...c-packets.html

I am running debian 8
 
Old 11-21-2016, 08:21 PM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 3,063

Rep: Reputation: Disabled
The Windows driver for your Ethernet card has probably disabled WoL. In that case, WoL won't work once you've booted into Windows and then shut the system down, unless you turn your computer manually back on again and let the BIOS POST reset the settings (which completely defeats the purpose of WoL).

Many Windows drivers can be told explicitly to leave WoL enabled. Take a look at the NIC driver in Device Manager, and see if you can find any WoL related settings on the "Advanced" tab. On my Atheros NIC it's called "Wake Up Capabilities", but each vendor seems to use their own terminology.
 
1 members found this post helpful.
Old 11-30-2016, 07:32 AM   #3
dave@burn-it.co.uk
Member
 
Registered: Sep 2011
Distribution: Puppy
Posts: 601

Rep: Reputation: 172Reputation: 172
Windows does NOT DISABLE wol unless you ask it to. WOL is a bios function anyway.
 
Old 11-30-2016, 07:43 AM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,907

Rep: Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510
Quote:
Originally Posted by dave@burn-it.co.uk View Post
Windows does NOT DISABLE wol unless you ask it to. WOL is a bios function anyway.
So you think it is still working?
 
Old 11-30-2016, 08:05 AM   #5
dave@burn-it.co.uk
Member
 
Registered: Sep 2011
Distribution: Puppy
Posts: 601

Rep: Reputation: 172Reputation: 172
If it was and isn't now it is not a Windows problem.
WOL is handled by the hardware and all it does is send a start signal to the CPU the same as pressing the ON button.
 
Old 11-30-2016, 08:31 AM   #6
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,907

Rep: Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510Reputation: 1510
Quote:
Originally Posted by dave@burn-it.co.uk View Post
If it was and isn't now it is not a Windows problem.
WOL is handled by the hardware and all it does is send a start signal to the CPU the same as pressing the ON button.
Unless disabled by Windows. It appears to have been working until Windows was booted...

It could easily be a Windows default that hasn't been changed.

Last edited by jpollard; 11-30-2016 at 08:32 AM.
 
1 members found this post helpful.
Old 11-30-2016, 08:51 AM   #7
dave@burn-it.co.uk
Member
 
Registered: Sep 2011
Distribution: Puppy
Posts: 601

Rep: Reputation: 172Reputation: 172
It is NOT a Windows function. It may have been disabled USING Windows but not BY Windows. It is NOT a Windows default to change it at all. It is purely to do with the power on settings in the card. The card does not know or care what OS is installed when it sends the signal.
 
Old 11-30-2016, 09:00 AM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,817

Rep: Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977
Quote:
Originally Posted by dave@burn-it.co.uk View Post
It is NOT a Windows function. It may have been disabled USING Windows but not BY Windows. It is NOT a Windows default to change it at all. It is purely to do with the power on settings in the card. The card does not know or care what OS is installed when it sends the signal.
Sorry, but it appears you're not reading what's being said here. The first reply, post #2, by Ser Olmy said specifically:
Quote:
Originally Posted by Ser Olmy
The Windows driver for your Ethernet card has probably disabled WoL. In that case, WoL won't work once you've booted into Windows and then shut the system down, unless you turn your computer manually back on again and let the BIOS POST reset the settings (which completely defeats the purpose of WoL).

Many Windows drivers can be told explicitly to leave WoL enabled. Take a look at the NIC driver in Device Manager, and see if you can find any WoL related settings on the "Advanced" tab. On my Atheros NIC it's called "Wake Up Capabilities", but each vendor seems to use their own terminology.
They never said it was by 'default', or anything else...no one else has either. The facts as stated by the OP support all of this because:
  • WOL was working, until...
  • ...they booted into Windows, and...
  • ...it STOPPED working afterwards
As Ser Olmy said initially...if the Windows driver turned off that feature, it won't work until you manually power off/back on the system, which sets thing back to what BIOS says it should be. No one said it was by default, but stated (correctly) that it *CAN BE* disabled.
 
Old 11-30-2016, 09:06 AM   #9
dave@burn-it.co.uk
Member
 
Registered: Sep 2011
Distribution: Puppy
Posts: 601

Rep: Reputation: 172Reputation: 172
And I am saying that the Windows driver will NOT have turned it off unless asked to do so.
 
Old 11-30-2016, 09:15 AM   #10
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,817

Rep: Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977
Quote:
Originally Posted by dave@burn-it.co.uk View Post
And I am saying that the Windows driver will NOT have turned it off unless asked to do so.
Right...which it obviously did.
 
Old 11-30-2016, 09:24 AM   #11
dave@burn-it.co.uk
Member
 
Registered: Sep 2011
Distribution: Puppy
Posts: 601

Rep: Reputation: 172Reputation: 172
IT wouldn't ask itself to do so!!

It may be that he installed some other software that turned it off, but Windows will not do it without being told to do so.

Last edited by dave@burn-it.co.uk; 11-30-2016 at 09:26 AM.
 
Old 11-30-2016, 09:46 AM   #12
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,817

Rep: Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977
Quote:
Originally Posted by dave@burn-it.co.uk View Post
IT wouldn't ask itself to do so!! It may be that he installed some other software that turned it off, but Windows will not do it without being told to do so.
Right..who is saying that it will do it by default, besides you?

It could very well be the OP turned it off, or that the driver they're using is an older one where it WAS disabled by default. They said "Windows"...for all we know, it's Windows Vista or XP, before that feature was even implemented in the driver they're using.
 
Old 11-30-2016, 10:10 AM   #13
dave@burn-it.co.uk
Member
 
Registered: Sep 2011
Distribution: Puppy
Posts: 601

Rep: Reputation: 172Reputation: 172
Quote:
Right...which it obviously did.
You did??
 
Old 11-30-2016, 10:16 AM   #14
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,817

Rep: Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977Reputation: 6977
Quote:
Originally Posted by dave@burn-it.co.uk View Post
You did??
Once again, you appear to not be reading (or understanding) what's been written, either purposefully or through inattention/trolling. You said:
Quote:
Originally Posted by dave@burn-it.co.uk
And I am saying that the Windows driver will NOT have turned it off unless asked to do so.
...to which I *REPLIED* "Right...which it obviously did." The meaning of this answer in a longer sentence (for you) is "Yes, the Windows driver turned off that feature, either due to it being an old driver, or by the user asking the driver to disable that particular feature". Does that make you happier???

Again/still: either it's an old driver, or it was turned off IN the driver intentionally. Why is this hard to grasp? NO ONE is now, or has been, saying Windows will by default turn that off. We ARE saying it CAN be turned off, and point to the obvious fact that it WAS, basing it on what the OP posted.

Last edited by TB0ne; 11-30-2016 at 10:18 AM.
 
Old 11-30-2016, 10:52 AM   #15
dave@burn-it.co.uk
Member
 
Registered: Sep 2011
Distribution: Puppy
Posts: 601

Rep: Reputation: 172Reputation: 172
And you or other people keep blaming or implying blame by Windows when that is not the case.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Wake On LAN in Linux, works in Windows furtivefox Linux - General 2 02-10-2015 12:34 AM
[SOLVED] Wake on LAN doesn't work over WAN earthw0rmjim Linux - Networking 4 07-22-2012 12:03 PM
[SOLVED] Wake on Lan doesn't work after Linux shutdown allanwiese Linux - General 8 12-30-2010 08:33 AM
Mail doesnt work on my CentOS in LAN kumars.nitin123 Linux - Server 2 11-05-2009 05:31 AM
How to get wake on lan to work with Ubuntu 9.04 darthfoolish Linux - Networking 1 10-01-2009 12:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration