LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-03-2015, 12:17 PM   #1
dthims
Member
 
Registered: Mar 2003
Posts: 50

Rep: Reputation: 1
vsftpd wont work for users added with /sbin/nologin


did useradd -s /sbin/nologin user1. then added /usr/sbin/nologin to
/etc/shells, but it still won't let those users ftp in. normal users
work fine. shouldn't this work? any help is appreciated

debian 3.2.0-4
vsftpd 2.3.5-3
 
Old 04-03-2015, 12:51 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Yes, it should work that way. It will be good if you share your vsftpd.conf file so that we will get better idea of the issue.
 
Old 04-03-2015, 01:21 PM   #3
dthims
Member
 
Registered: Mar 2003
Posts: 50

Original Poster
Rep: Reputation: 1
listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
local_root=/var/ftp/pub
listen_port=21
pasv_enable=YES
allow_writeable_chroot=YES
xferlog_file=/var/log/vsftpd.log
ftpd_banner=welcome
deny_email_enable=YES
banned_email_file=/etc/vsftpd.banned_emails
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/chroot_list
secure_chroot_dir=/var/run/vsftpd/empty
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/private/vsftpd.pem
ssl_enable=YES
allow_anon_ssl=NO
force_local_data_ssl=YES
force_local_logins_ssl=YES
ssl_tlsv1=YES
ssl_sslv2=YES
ssl_sslv3=YES
require_ssl_reuse=NO
ssl_ciphers=HIGH
 
Old 04-03-2015, 01:26 PM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Did you try creating a normal user and then changing the shell to /sbin/nologin or /bin/false by editing /etc/passwd or using usermod. Do you see any difference when you set it to /bin/false instead of /sbin/nologin.
 
Old 04-03-2015, 01:36 PM   #5
dthims
Member
 
Registered: Mar 2003
Posts: 50

Original Poster
Rep: Reputation: 1
same thing, it won't let you in. this worked in the past. had it setup this way
 
Old 04-03-2015, 01:40 PM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
As you said it worked in past what changed you have made to the system since then. Any changes recently performed which resulted in this. When you try to login with the user who have got shell set to /sbin/nologin what is the exact error message that you get? Did you try taking packet trace. If yes, what do you see in packet trace?

Last edited by T3RM1NVT0R; 04-03-2015 at 01:45 PM.
 
Old 04-03-2015, 01:43 PM   #7
dthims
Member
 
Registered: Mar 2003
Posts: 50

Original Poster
Rep: Reputation: 1
it says fail login
 
Old 04-03-2015, 01:47 PM   #8
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
You are not answering to all the queries, without the details how we suppose to know what's going on? You said failed login but what about the error code and what about the other questions that I have posted?
 
Old 04-03-2015, 01:52 PM   #9
dthims
Member
 
Registered: Mar 2003
Posts: 50

Original Poster
Rep: Reputation: 1
set it up a while back and i'm setting it up again because i have a need again. login failed is the only message i get
 
Old 04-03-2015, 02:06 PM   #10
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Do you have config file from the previous setup. Did you compare the previous and the current config file. As you said you are setting it up again that means it did not work in past. I mean this is a new setup and it never worked with /sbin/nologin. The best way I can think of is to first compare the configs files from previous setup with this one. If that doesn't give you any clue then go with packet trace to see if you find something there.
 
Old 04-04-2015, 06:21 AM   #11
dthims
Member
 
Registered: Mar 2003
Posts: 50

Original Poster
Rep: Reputation: 1
http://forums.debian.net/viewtopic.php?f=30&t=114249
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp users /bin/bash rather than /sbin/nologin ? anon091 Linux - Newbie 2 04-10-2013 08:17 AM
[SOLVED] Ubuntu 9.04, chpasswd & /usr/sbin/nologin Feetloaf Ubuntu 4 07-15-2010 07:20 PM
/bin/false vs /sbin/nologin - difference? ziggie216 Linux - General 1 12-22-2005 02:59 AM
sendmail adduser sbin/nologin using php mhatre kedar Linux - Networking 0 04-18-2005 01:12 AM
/sbin/nologin tyccea Red Hat 2 10-22-2003 07:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration