LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-20-2005, 04:03 PM   #16
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30

Ok well mabye this helps. When I connect to this server on this server I get this error:
Code:
500 OOPS: vsftpd: security: 'one_process_model' is anonymous only
 
Old 03-21-2005, 08:44 AM   #17
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
This is from your config file:

Quote:
one_process_model=YES
According to the vsftpd man page, the default for this is NO. Is there a reason why you changed this? Please note that I'm also just guessing about this being the cause of the error you're seeing.
 
Old 03-21-2005, 12:09 PM   #18
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
Well that solves that problem. I can now log in as anonymous on this server, but I get a 530 error: login incorrect. whenever I try to log in as a user. What could be causing this?
 
Old 03-21-2005, 02:16 PM   #19
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
I'm not sure how you would check this on RH9, but do you know if you use /etc/passwd for user accounts or do you use PAM? Using local_enable checks the user against /etc/passwd, and if RH9 uses PAM for authentication, that may account for the error you see. Unfortunately, since I use Slackware (which doesn't use PAM), I have no advice either on how to check if you are using PAM and if you are, how you get vsftpd to use it.

You also might want to turn on log_ftp_protocol and see if logging additional information can shed some light on what is going wrong.

I suppose it is also possible that if you have been messing with userlist_enable and userlist_deny, you might be causing this sort of an issue. It might not be a bad idea to make sure they are both set to their default.
 
Old 03-21-2005, 03:27 PM   #20
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
Well I never installed PAM. Ill check and see if it is there. If it is, I will have to recompile vsftpd with the PAM option.
 
Old 03-22-2005, 02:27 PM   #21
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
You were right. I did have PAM installed on this system. All I had to do was copy over a file and now I can log in. Thank you very much!
 
Old 03-22-2005, 02:47 PM   #22
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Cool. I'm glad it was PAM because otherwise I'm outta ideas
 
Old 03-22-2005, 05:23 PM   #23
buffed317
Member
 
Registered: Jun 2004
Location: New Jersey, USA
Distribution: Slackware 11
Posts: 191

Rep: Reputation: 31
i am having the same problem. what file did you copy over? how did you include pam support during installation?

thanks

snowsurfair: that winxp link has to be the funniest thing i have ever seen

Last edited by buffed317; 03-22-2005 at 06:43 PM.
 
Old 03-22-2005, 11:35 PM   #24
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
First off, I did a little google linux search and someone was having the same problem with wuftpd, or something. Anyway to find out you have PAM open a terminal and type:
Code:
rpm -qa | grep pam
If you have it installed it should list them. I had a couple listed. If you need them I will post them, but as long as you come up with something, you should have PAM installed.

Since I did have it installed, I referred to the install file and it says to do this as root:
Code:
cp RedHat/vsftpd.pam /etc/pam.d/ftp
You have to do that in the directory that you unpacked the tar file. It just copies the file from the RedHat folder to the place it needs to be. I did not have to recompile it because when I did try it said that it already was the newest version. To clarify, I thought the instructions said it needed PAM support compiled into it, but it turned out it only needed that file copied. Hope this helps.

P.S. I though that winxp thing was hilarious also.
 
Old 03-23-2005, 08:33 AM   #25
buffed317
Member
 
Registered: Jun 2004
Location: New Jersey, USA
Distribution: Slackware 11
Posts: 191

Rep: Reputation: 31
the file copy fixed it for me too. thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd settingd and VSFTPD DEAD BUT SUBSYS LOCKED pc_copat Linux - Newbie 15 11-05-2009 11:31 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 02:05 AM
VSFTPD - FC2 - Virtual User Trouble Emzer Linux - Software 2 02-26-2005 06:13 AM
vsftpd trouble neocookie Linux - Software 4 10-20-2004 12:09 PM
more vsftpd config trouble noisybastard Linux - Networking 5 05-08-2003 12:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration