LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-17-2005, 02:08 PM   #1
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Rep: Reputation: 30
vsFTPd trouble


Hello,

I am running Red Hat 9.0 and have installed vsFTPd on this comp. I tried installing Proftpd, but that did not work(I'm pretty sure that I got all the files from it uninstalled). Anyway, I got vsFTPd all installed, but have run into a snag. I can only log in as anonymous, I can't log in as any of the users on the comp. Even when I try to log in as a user it says "this server is Anonymous only." I want to have it set up as users on the computer can long in remotely and be restricted to their home directory, and any sub-directories. I have read over the readme and install files, but non tell how to do this/ fix it if it doesn't work. Thanks for your help in advance.

Last edited by SnowSurfAir; 03-17-2005 at 02:12 PM.
 
Old 03-18-2005, 07:51 AM   #2
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,426

Rep: Reputation: 95
emacs /etc/vsftpd.conf
 
Old 03-18-2005, 08:16 AM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Linux.tar.gz is right in that the settings you need to alter are in the /etc/vsftpd.conf file, including the ability to chroot users to their home directory. There isn't a lot of documentation in that file, but the vsftpd web site does have some better explanations of the various options. You probably do want to look at that as not all of the options are included in the default config file. Vsftpd.conf can be edited with pretty much any text editor so whether or not you use emacs depends on your pain threshold.....
 
Old 03-18-2005, 12:35 PM   #4
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
And editing that will allow me to make users on this computer be able to log in on their own names?
 
Old 03-18-2005, 01:38 PM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Yeah, that should do the trick. If I remember correctly, this is one of the options in the default vsftpd.conf file so you just need to change it and re-start the server.
 
Old 03-18-2005, 08:09 PM   #6
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
OK well that solves that but I am getting an error when I try to log in remotely. I try to log in with my username and password, but it will not let me log in, it says that it does not recognize my name. I have also checked password and username.

Also, when I type vsftpd in the command prompt I get this error:
Code:
500 OOPS: could not bind listening IPv4 socket
I'm not exactly sure on how to fix that. Also, how do I shut down/restart the server? Thanks and sorry for my naiveness.
 
Old 03-18-2005, 08:28 PM   #7
manhcuong
LQ Newbie
 
Registered: Mar 2005
Location: Viet Nam
Posts: 11

Rep: Reputation: 0
Hi ,everyone
I'm Vietnamese , i speak English very bad , but i have a proplem ,could you help me ?
On RedHat 9 ,i was install Wine (wine-20050310-1fc3winehq.i686.rpm ) and have an error :
[root@localhost down]# dir
fonts.cache-1 wine-20050310-1fc3winehq.i686.rpm
wine-20050310-1fc3winehq.i386.rpm
[root@localhost down]# rpm -ivh wine-20050310-1fc3winehq.i686.rpm
Preparing... ########################################### [100%]
1:wine ########################################### [100%]
[root@localhost down]# wine
wine: creating configuration directory '/root/.wine'...
err:module:load_builtin_dll failed to load .so lib for builtin L"gdi32.dll": libstdc++.so.6: cannot open shared object file: No such file or directory
err:module:import_dll Loading library gdi32.dll (which is needed by L"c:\\windows\\system\\user32.dll") failed (error c000007a).
err:module:import_dll Library user32.dll (which is needed by L"C:\\windows\\rundll32.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\rundll32.exe" failed, status c0000135
wine: wineprefixcreate failed while creating '/root/.wine'.
[root@localhost down]# wineserver: could not save registry branch to /root/.wine-r7iTQb/system.reg : No such file or directory
wineserver: could not save registry branch to /root/.wine-r7iTQb/userdef.reg : No such file or directory
wineserver: could not save registry branch to /root/.wine-r7iTQb/user.reg : No such file or directory
Help me , I don't know what it need.

Last edited by manhcuong; 03-18-2005 at 08:30 PM.
 
Old 03-18-2005, 09:20 PM   #8
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
You might want to start a new thread for this. If sounds like you have a windows-problem though.
 
Old 03-19-2005, 06:06 AM   #9
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,426

Rep: Reputation: 95
Quote:
Originally posted by SnowSurfAir
OK well that solves that but I am getting an error when I try to log in remotely. I try to log in with my username and password, but it will not let me log in, it says that it does not recognize my name. I have also checked password and username.

Also, when I type vsftpd in the command prompt I get this error:
Code:
500 OOPS: could not bind listening IPv4 socket
I'm not exactly sure on how to fix that. Also, how do I shut down/restart the server? Thanks and sorry for my naiveness.
It's probably a conflict between inetd or xinetd (BSD super server) and vsftp in standalone mode.
check /etc/inetd.conf
Running a net application throught inetd is a good way to save resources, because inetd start a net server only if there's a request on it's port. But first, it's better to desactivate this and run apps in standalone mode in order to test them.
 
Old 03-19-2005, 11:28 AM   #10
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
I'm not sure if I have inetd installed on this comp, because when I type in pico /etc/inetd.conf I don't get anything it says a new file.
 
Old 03-19-2005, 03:53 PM   #11
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
I believe Red Hat has used xinetd as a replacement for inetd. Do you have a xinetd.conf file?
 
Old 03-19-2005, 09:51 PM   #12
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
I do have a xinetd config file in /etc/xinetd.conf. In it is:
Code:
#
# Simple configuration file for xinetd
#
# Some defaults, and include /etc/xinetd.d/

defaults
{
        instances               = 60
        log_type                = SYSLOG authpriv
        log_on_success          = HOST PID
        log_on_failure          = HOST
        cps                     = 25 30
}

includedir /etc/xinetd.d
Is this all correct? Also, I have vsFTPd set to stand alone, should I change this?

Last edited by SnowSurfAir; 03-19-2005 at 10:07 PM.
 
Old 03-20-2005, 07:05 AM   #13
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,426

Rep: Reputation: 95
Ok, so let's do simple. Don't run vsftp in standalone. So xinetd run it for you, then if you want to restart vsftp when you make changes to vsftp.conf, simply restart xinetd.
 
Old 03-20-2005, 01:55 PM   #14
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
I can now log into my server as a local user, but when I log in, either as anonymous or a local user, I get an error that says that the document contains no data, this is when I log in on the sever itself. When I try to log in from a remote computer, I can't even log in, wither as anonymous or a local user. Here is my config file:
Code:
# Access rights
anonymous_enable=YES
local_enable=YES
write_enable=YES
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
chroot_local_user=YES

# Security
anon_world_readable_only=YES
connect_from_port_20=YES
hide_ids=YES
pasv_min_port=50000
pasv_max_port=60000
# Features
xferlog_enable=YES
ls_recurse_enable=NO
ascii_download_enable=NO
async_abor_enable=YES
# Performance
one_process_model=YES
idle_session_timeout=120
data_connection_timeout=300
accept_timeout=60
connect_timeout=60
anon_max_rate=50000
This is from the sample file. I also put a vsftpd.xinetd in my /etc/ directory. Should I have done that?

Last edited by SnowSurfAir; 03-20-2005 at 03:17 PM.
 
Old 03-20-2005, 03:24 PM   #15
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Quote:
This is from the sample file. I also put a vsftpd.xinetd in my /etc/ directory. Should I have done that?
Probably not. You need to have /etc/vsftpd.conf set up with your desired configuration and you need to have xinetd.conf set up so it uses vsftpd as it ftp server. Since I don't use xinetd, I can't post any configurations, but I bet a little searching here should turn up an example or two
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd settingd and VSFTPD DEAD BUT SUBSYS LOCKED pc_copat Linux - Newbie 15 11-05-2009 11:31 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 02:05 AM
VSFTPD - FC2 - Virtual User Trouble Emzer Linux - Software 2 02-26-2005 06:13 AM
vsftpd trouble neocookie Linux - Software 4 10-20-2004 12:09 PM
more vsftpd config trouble noisybastard Linux - Networking 5 05-08-2003 12:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration