LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   VSFTPD Not responding to restart/stop/start commands even in root! (https://www.linuxquestions.org/questions/linux-software-2/vsftpd-not-responding-to-restart-stop-start-commands-even-in-root-360179/)

phoenix09 09-04-2005 05:04 PM

VSFTPD Not responding to restart/stop/start commands even in root!
 
Hey-

I have no idea why this happens, but my vsftpd server will not respond to my command to make it restart/start or stop. I do the command
Code:

/etc/init.d/vsftpd restart
from inside a sudo -s so i have root privilages. It worked fine beforebut after a bit more editing to my vsftpd.conf file it starte ignoring my commands.After putting the command /etc/init.d/vsftpd restart it just creates a new line and disregards the command altogether.
Any ideas why this happens?

Thanks for your help im totally stumped!

teebones 09-04-2005 05:40 PM

Did you edited the file when the daemon was still running? guess so.
this will confuse the daemon. (because it detects a new config, when the old is still running as an old process wich i not linked to the new session).
Kill the process first , then try doing the start/stop/restart things again.. likely it works again.

phoenix09 09-04-2005 06:28 PM

actually that wasnt the problem but i did find out what was causing it. ... i needed to include listen=yes for the server to run at all! lol i had taken it out in editing the conf. file but now i fixed it.

i still have a major problem getting write permission with my main account... anyone know how i enable a user account to have read/write privilages?

id really appreciate any help now-thanks so much

twantrd 09-04-2005 08:30 PM

"listen=yes" means that vsftpd will run as a standalone daemon. Looks like you had vsftpd running from inetd or xinetd (for redhat). If it was really running from inetd, then you need to restart inetd (just HUP it) for the config change to take into effect.

-twantrd

phoenix09 09-05-2005 01:09 AM

im currently running kubuntu 3.4.1.
I restarted inetd and vsftpd and the write permission still isnt working.
Heres a copy of my vsftpd.conf file:
Code:

# Example config file /etc/vsftpd.conf
#-----------------------------
#Config file v1.2 - "Lets hope this works..."
#-----------------------------
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=077
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
vsftpd_log_file=/opt/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner=Welcome to the vsftp daemon v1.0.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/opt/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/opt/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
ls_recurse_enable=YES
#Security- Disable unauthorized access
userlist_enable=YES
userlist_file=/etc/vsftpd.user_list
#
#Enabling different user level-access privilages
user_config_dir=/etc/vsftpd_user_conf
#You need this line  for ftpserver to run!
listen=yes


Any ideas on why it still isnt letting me do a "mkdir" or any write command in my ftp client (filezilla)?

twantrd 09-05-2005 02:20 PM

Quote:

I restarted inetd and vsftpd and the write permission still isnt working
Remember what I just said. You have "listen=yes" so you DO NOT need to restart inetd. It doesn't hurt, but there's really no need to do that. You just need to restart vsftpd.

Quote:

Any ideas on why it still isnt letting me do a "mkdir" or any write command in my ftp client (filezilla)?
This has NOTHING to do with vsftpd. This has to do with your unix directory permissions. Look at the home directory of the ftp account and make sure they are the owner or that they belong to a group that has write permissions.

-twantrd

phoenix09 09-05-2005 03:36 PM

ok i did chmod and gave my user full permissions, without allowing write/execute for the "other". heres what my ls -l reveals inside my /home/ folder:
Code:

total 12
drwxrwxr--  2  user09    nogroup        4096 2005-09-02 16:04 ftp
drwxr-x---  2    root        root                4096 2005-09-03 00:16 movies
drwxrwxr--  4  user09    user09            4096 2005-09-02 15:09 user09

and im still getting a 550 permission denied error! what is wrong here?


thanks---im so sorry im such a noob but this is just driving me crazy

twantrd 09-06-2005 12:28 AM

Hmm, interesting. The permissions do look correct to me. If the user was able to write and make directories under a shell account for those 2 directories then something must be up with vsftpd. I could be wrong with saying that "this has NOTHING to do with vsftpd". Let's see if I am :). I have never used the option "user_config_dir=/etc/vsftpd_user_conf" before. I think this may be the culprit.

Taking a look, have you created '/etc/vsftpd_user_conf/user09'? You probably don't have that file. To create it:

cp /etc/vsftpd.conf /etc/vsftpd_user_conf/user09

Let me know if that works for you.

-twantrd


All times are GMT -5. The time now is 08:10 PM.