-   Linux - Software (
-   -   vsFTPd local user can't create directories (

nuzzy 11-04-2003 03:04 PM

vsFTPd local user can't create directories
Hi all,

I have my vsftpd.conf set up to only allow local users to log in to a specified root directory. They cannot upload or create files/folders in the directory however. I have "write_enable" set to "YES" so I'm not sure what is wrong.

david_ross 11-04-2003 03:23 PM

Do they have correct unix permissions on that directory?

nuzzy 11-04-2003 03:37 PM

Yes - I even tested it with 777 to make sure it wan't that and I still cannot write to it

david_ross 11-04-2003 03:38 PM

can you post vsftpd.conf

nuzzy 11-04-2003 03:52 PM

# Example config file /etc/vsftpd.conf
# The default compiled in settings are very paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Allow anonymous FTP?
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
# You may fully customise the login banner string:
ftpd_banner=Welcome to the Palm Andover FTP site.
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.

#enable for standalone mode

markus1982 11-04-2003 04:09 PM

Maybe does help you :-)

david_ross 11-05-2003 01:00 PM

Perhaps it is because you have chroot_local_users and a local_root

nuzzy 11-06-2003 08:41 AM

solved FW was set for incoming FTP to be read only....

maniax 06-26-2006 03:06 AM


Originally Posted by nuzzy
solved FW was set for incoming FTP to be read only....

ok, i have exact same problem, please tell me exactly what you did to get it work ? ( i am a linux noob )


maniax 06-26-2006 04:02 AM

Problem solved !

All others who have same problem just simply disable SELinux !!!

by doing "setenforce 0"
You can enable it back with "setenforce 1"

now my vsftpd works as expected :)

lefty.crupps 07-26-2011 08:57 AM

Enable the write?
I resolved this on Ubuntu 11.04 (I think? kernel 2.6.35) be editing the /etc/vsftp.conf file and uncommenting out these two lines:


And then restarted the VSFTP app:

shell#  /etc/init.d/vsftp restart
Tested successfully.

cypher_zero 12-04-2011 10:45 PM


All times are GMT -5. The time now is 04:14 PM.