LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-23-2003, 02:48 PM   #1
peteABK
Member
 
Registered: May 2003
Location: Canada
Distribution: Fedora 13
Posts: 49

Rep: Reputation: 15
vsftpd error message


I finally got my linux box running vsftpd last night so I thought I would attempt jailing users, but it didn't go as planned, I restored all the files that I changed and deleted the files that I created ( /etc/vsftpd.chroot_list )

But now I'm getting the error message:

500 OOPS str_getpwnam: ftpsecure

whenever I try to log-in using gftp on my other computer. I'm assuming that this has something to do with not being able to retrieve usernames, I was wondering if anyone else had seen this one before and might offer some advice. Thanks
 
Old 05-23-2003, 04:42 PM   #2
hamster
Member
 
Registered: Apr 2003
Location: Waterford, Ireland
Distribution: Mandrivia 2006.1, Ubuntu 7.10
Posts: 188

Rep: Reputation: 30
Hi peteABK.

What linux distro are you using? Mandrake, Redhat... ?
 
Old 05-23-2003, 05:10 PM   #3
peteABK
Member
 
Registered: May 2003
Location: Canada
Distribution: Fedora 13
Posts: 49

Original Poster
Rep: Reputation: 15
Redhat 9 hopefully you can help

thanks
 
Old 05-23-2003, 05:34 PM   #4
hamster
Member
 
Registered: Apr 2003
Location: Waterford, Ireland
Distribution: Mandrivia 2006.1, Ubuntu 7.10
Posts: 188

Rep: Reputation: 30
peteABK,

I have RedHat 9 myself. When I did my install of RH9 I choose nearly everything. Would vsftpd have stopped?
/sbin/service vsftpd status tells you it is still running?

There is an faq here that mentions that error you are getting:
http://mrtg.planetmirror.com/pub/vsf...ftpd-1.1.2/FAQ

Maybe help?
 
Old 05-25-2003, 03:38 AM   #5
peteABK
Member
 
Registered: May 2003
Location: Canada
Distribution: Fedora 13
Posts: 49

Original Poster
Rep: Reputation: 15
Sorry but that's not the problem, vsftpd is running and I checked the faq, it says that the user "nobody" propbably isn't present but it is and it is in the allowed file too.

Thanks for you help, but the problem remains.
 
Old 05-25-2003, 05:05 AM   #6
peteABK
Member
 
Registered: May 2003
Location: Canada
Distribution: Fedora 13
Posts: 49

Original Poster
Rep: Reputation: 15
hamster,

I would like to thank you for you help, after scanning through these forums for a while and downloading a fresh config file, I finally walked myself through this and I don't have this problem any more. I can't really say what was wrong, all I did was change the config file one item at a time. But thanks again.
 
Old 05-28-2003, 08:01 AM   #7
giraff
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
Question

Just emerged vsftpd, gone through the manuals, and put the following .conf together:
------------------------------------------------
# $Header: /home/cvsroot/gentoo-x86/net-ftp/vsftpd/files/vsftpd.conf,v 1.2 2002/05/04 03:42:50 woodchip Exp $

### General settings
ftpd_banner=Welcome to giraff FTP service.
listen=YES
max_clients=5
max_per_ip=4
connect_from_port_20=YES
setproctitle_enable=YES
text_userdb_names=YES
nopriv_user=ftp
dirmessage_enable=YES
message_file=.message
write_enable=YES

### Anonymous access
anonymous_enable=NO
no_anon_password=YES
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
anon_root=/home/ftp
ftp_username=ftp
anon_umask=077
anon_max_rate=50000
#chown_uploads=YES
#chown_username=root

### Local users
local_enable=YES
chroot_local_user=YES
local_umask=077
local_max_rate=0
#chroot_list_enable=YES
#chroot_list_file=/etc/vsftpd/vsftpd.chroot_list

### Guest
guest_enable=NO
guest_username=ftp

### ASCII transfer
ascii_upload_enable=NO
ascii_download_enable=NO

### Logging
xferlog_enable=YES
xferlog_file=/var/log/vsftpd/vsftpd.log

### Performance
idle_session_timeout=120
data_connection_timeout=120
accept_timeout=60
connect_timeout=60
----------------------------------------------------

By probing #vsftpd & I got the 500 oops: missing value in config file.
Any ideas? I looked through the .conf manual but ain't got a clue what I've missed.
 
Old 05-31-2003, 05:31 AM   #8
peteABK
Member
 
Registered: May 2003
Location: Canada
Distribution: Fedora 13
Posts: 49

Original Poster
Rep: Reputation: 15
To be honest I'm still having troubles letting users log in from other computers. But when I ftp on the local maching it works fine. What I would try is add this to your configuration file:

pam_service_name=vsftpd
(from what I have found so far is that this allows vsftpd to access your user and groups configurataion, checking passwords etc)

userlist_deny=NO
userlist_file=/etc/vsftpd.user_list

(the first line says that you should not deny the users in the userlist_file, changing it to "YES" will deny them, the second line just points to the file with the user names)

chroot_list_enable=YES
chroot_list_file=/etc/vsftpd/vsftpd.chroot_list

(the first line here tells vsftpd to "jail" the users to their specified home directory, the file in the second line should contain the same user names as the the file in the userlist_file above so that it is consistant for every user)

I hope this helps a little, I know it's not the complete solution but I got side-tracked on apche virtual hosting for a while, if you find out anything else I would appreciate the post.

Good luck
 
Old 05-31-2003, 05:47 AM   #9
peteABK
Member
 
Registered: May 2003
Location: Canada
Distribution: Fedora 13
Posts: 49

Original Poster
Rep: Reputation: 15
giraff

I know I just replied to your post, but I was playing with my server a bit and figured out that it is working. I'm sure I have more tweaking to do, but if you want a working copy of vsfpd.conf I'll share mine with you check out

www.virtualoutsource.net/vsftpd.conf

that should get you started.
 
Old 06-02-2003, 02:20 PM   #10
giraff
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
Thanx, I'll give it a shot as soon as I finish my exam... )
 
Old 06-20-2003, 08:08 PM   #11
sagan
LQ Newbie
 
Registered: Jun 2003
Posts: 2

Rep: Reputation: 0
Hello All, I noticed this happening after I did the latest sp update for redhat 9. in the vsftpd.conf file there is a tag that is nopriv_user=ftpsecure in my orig conf it was remed out but in the "updated" conf it is active. I remed it out again and this error went away. I hope this helps

Sagan
 
Old 06-20-2003, 08:40 PM   #12
sagan
LQ Newbie
 
Registered: Jun 2003
Posts: 2

Rep: Reputation: 0
Hello All, I noticed this happening after I did the latest sp update for redhat 9. in the vsftpd.conf file there is a tag that is nopriv_user=ftpsecure in my orig conf it was remed out but in the "updated" conf it is active. I remed it out again and this error went away. I hope this helps

Sagan
 
Old 07-14-2003, 11:38 PM   #13
kakridge
LQ Newbie
 
Registered: Jul 2003
Distribution: Red Hat 9.0
Posts: 12

Rep: Reputation: 0
Ok, I don't know if I have a user account(well, I run usermod nobody and I don't get a "user doesn't exist" error. I am getting the str_getpwnam: ftpsecure error.

This is very frustrating. Any advice is appreciated.
 
Old 10-25-2003, 12:58 AM   #14
Andevellicus
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
I've been trying to do the whole "vsftp" thing as well, and I too got the 500 OOPS str_getpwnam: ftpsecure error message. I commented out the nopriv_user field in vsftpd.conf and I could log in locally, so I think it's a problem with that
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Vsftpd Error rlillard Linux - Software 1 11-23-2005 12:13 AM
QMAIL error:554 Transaction failed: message format error mpk25 Linux - Software 1 10-15-2004 12:53 PM
error message when run MRTG: SNMP error zhgalaxy Linux - Newbie 0 02-18-2004 12:08 PM
why this error message is appear in xsession-error file? eye Red Hat 0 10-21-2003 07:51 AM
When I upgrade vsftpd , get erroe message setactive Linux - Software 2 05-26-2003 01:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration