LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-14-2003, 12:36 AM   #1
hda
LQ Newbie
 
Registered: Sep 2003
Distribution: Red Hat 9.0
Posts: 4

Rep: Reputation: 0
vsftpd config


Hello....

i had vsftpd working for a while... i think it was working somewhat because the default config seemed to work... i could download certain files but sometimes i'd get 550 error when trying to get larger files... I changed my config to this-
anonymous_enable=NO
local_enable=YES
write_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
chroot_local_user=YES
guest_enable=YES
guest_username=virtual
listen=YES
listen_port=10021
pasv_min_port=30000
pasv_max_port=30999
xferlog_enable=YES
xferlog_file=/home/hda/vsftdp/vsftpd.log
xferlog_std_format=YES

and now i cant even get on... if anyone could help me it would be awesome thanks.
btw i'm running rh9
PS how do i make pop-up messeges when people log on?
 
Old 10-14-2003, 02:06 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Welcome to LQ.

What error do you get when you try to login?
Do you get a login prompt?
Is vsftpd running? "ps -ef | grep vsftpd"

To give a message when someone logs in create a text file and point to it with a variable in vsftpd.conf eg:
banner_file=/etc/ftp_welcome
 
Old 10-14-2003, 07:50 PM   #3
hda
LQ Newbie
 
Registered: Sep 2003
Distribution: Red Hat 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
OK ... i recently changed my config and i'll post it again at the end.... As the first time, people can connect to me, and can move around and such. However, they can download text files on my server, but not 50 MB zip files. When they try, it says
Error 550: Unable to Open file.

Here is my config right now.. if anyone could help me solve this problem i would be very greatful.


anonymous_enable=NO
local_enable=YES
write_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO

anon_world_readable_only=NO
connect_from_port_20=YES
hide_ids=YES
pasv_min_port=50000
pasv_max_port=60000

xferlog_enable=YES
ls_recurse_enable=NO
ascii_download_enable=NO
async_abor_enable=YES

one_process_model=NO
idle_session_timeout=120
data_connection_timeout=300
accept_timeout=60
connect_timeout=60
anon_max_rate=50000

Also, let me know if i need to change my other files such as vsftpd.ftpusers or anything else.

Thanks
 
Old 10-15-2003, 12:56 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Are the permissions on the zip files the same as the text files?
 
Old 10-15-2003, 02:45 PM   #5
wendallsan
Member
 
Registered: Jun 2003
Posts: 36

Rep: Reputation: 15
I know nothing of vsftpd (sorry!), but I think I remember that there are 2 modes in ftp: asci and binary-- w/ asci, you can only download text files, in binary mode you can download anything. I'm not sure if this is set only on the client or both in the client and server. I'm I'm totally off here, somebody kick me and tell poor hda not to listen to me!

If things work out for you, let me know-- I'm trying to get proftpd to work myself, and if that doesn't work out, maybe I'll try vsftpd (using your config file, of course, hehe).

good luck!

wendallsan
 
Old 10-15-2003, 10:29 PM   #6
hda
LQ Newbie
 
Registered: Sep 2003
Distribution: Red Hat 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
Actually, i dont know how to set or even view permissions on any of the files. If you could let me know, thatd be nice, because i think that is prabably the problem.
 
Old 10-16-2003, 10:34 AM   #7
wendallsan
Member
 
Registered: Jun 2003
Posts: 36

Rep: Reputation: 15
to view file privileges from the terminal, use the command "ls -all" -- this is the normal list command, but the -all option shows more details about the files you're listing. You'll get something like this:

-rw-r--r-- 1 root root 4 Oct 16 08:13 test.txt

this lists, in order, the permissions, a 1 charater (I don't know what that column is for!), the file's owner (root), the file's group that owns it (root group), the file's size (4 bytes) the date it was created, and finally the file's name.

that 1st bit there is the permissions. the 1st char is pretty much either a dash for a normal file or a d for a directory. After that 1st char, you have 3 sets of chars, these sets correspond to the file's owner, the file's group, and anyone else. You can set permissions for read, write, and execute. So, with our example above, the file is read and write-able for the owner, but not executable, and is readable by the group and other users, but not write-able or executable to them. So one more time, if we break up that permissions char set, we get:

- rw- r-- r--

1st dash means the file is not a directory
1nd set (rw-) is for the file owner (root), this means that the root user can read and write to the file. If the file were executable, the code would be rwx.
2nd set (r--) means that members of the group that owns the file (which is the root group in this example) can read the file, but can't write to it or execute it.
3rd set (r--) means that all other users have the same privileges as members of the group that owns this file -- they can read the file, but can't do anything else to it.

you use the chmod command to change permissions. It's a fairly weird command, so I suggest you read the man pages on it (type in "man chmod" from your terminal) to figure it out and post back here if you get confused.

you use chown to change a file's owner and group. That command is formatted like this:

chown newOwner[:newGroup] fileName

you replace newOwner with the user's name you want to change the file's ownership to. The newGroup section is optional, and only used when you want to change a file's group that owns it. Make sure you put the file name of the file you want to change last in the command.

That should be a good start to get you going. Alternately, if you're using KDE, you can cheat and just right-click on a file, go to the file's properties, and there is a tab in the properties window that you can use to change permissions and ownership using a gui instead of a command prompt. This works pretty well when you're not doing something in batch.

Try it out and let us know if you get stuck!

wendallsan
 
Old 10-16-2003, 10:37 AM   #8
snerfu
Member
 
Registered: Sep 2003
Distribution: Debian/GNU
Posts: 30

Rep: Reputation: 15
Alot of times I see a 550 error problem on FTP clients when between firewalls. Try setting to passive mode. If you have it turned on try turning passive off.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Vsftpd Config ? Is this possible? Jukas Linux - Software 5 11-03-2005 07:51 PM
VSFTPD config issue MbowerARA Linux - Networking 9 04-04-2005 06:36 PM
VSFTPD config problem nadsab Linux - Software 0 08-05-2004 02:37 PM
VSFTPD Debian VSFTPD "unrecognised variable in config file" DCT Linux - Software 0 05-29-2004 11:59 PM
more vsftpd config trouble noisybastard Linux - Networking 5 05-08-2003 11:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration