LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   VSFTP on Gentoo - directory listing failed (https://www.linuxquestions.org/questions/linux-software-2/vsftp-on-gentoo-directory-listing-failed-264289/)

animehair 12-08-2004 11:12 PM

VSFTP on Gentoo - directory listing failed
 
Here is the setup:
VSFTP on Gentoo using a chosen listen port, and defined passive ports. The defined listen port and passive ports are all fowarded on my router ot the private IP that my server set to. Furthermore the server is setup on the DMZ (also configured on my router).

My problem is:
I can ftp correctly within my private network, however whenever someone tries to ftp from outside my network they recieve an error message that the directory listing failed. The ftp client logs confirm that they are authenticating (username and password are accepted) but i cant figure out the problem from here. Interesting enough, the ftp client (outside my network) is showing my internal server IP address in the error message. This dosnt seem right to me.

I have googled for a while, and the message board is my last hope. If any further information is needed let me know, ill work with you. Thank you in advance.

hw-tph 12-09-2004 09:02 AM

Make sure that the clients use passive mode for connecting. Also set pasv_address= in your vsftpd.conf to your public IP (the address of the router's external interface), if you don't do this the transfer will fail.

Commands aren't sent through the data channel so usually you can log in but get no dir listing or download anything if the command channel is OK but the data transfer channel is not.


Håkan

animehair 12-09-2004 05:18 PM

BINGO!
 
wow, this worked! Oddly in the past i never had to configure this....then again this is the first time ive used VSFTP., before i used ProFtp. But may i pick your brain once more?......

May i use a Domain Name instead of the IP address? I plan to purchase a domain name, however currently Im just using the IP provided from my ISP (which isnt static). Thanks very much for your help....take care.

hw-tph 12-10-2004 04:01 AM

I think it has to be a numerical IP address...but then again I have never tried using a DNS name - and trying it won't hurt.


Håkan

tcma 12-10-2004 10:07 AM

Konqueror - ftp and web browser program
 
Another program to try is Konqueror which is a ftp and web browser program running on KDE.
You type the ftp address with user id and IP addresses like this on the location box:
ftp://tcma@192.168.2.180


All times are GMT -5. The time now is 04:25 AM.