-   Linux - Software (
-   -   VSFTP connection closed by remote server (

newuser455 03-30-2006 10:25 PM

VSFTP connection closed by remote server
I am using VSFTPD as my FTP server, and have been experiencing problems. I have tried various FTP clients, and I get similar errors with all of them.

What happens is that I will start to upload some files, usually around 5mb. After about 5-8 minutes (about 1-2 mb of 50 files transferred), SmartFTP comes up with the error, "An established connection was aborted by the software in your host machine.". I searched the error on google with no avail. Does anyone know what could be wrong, or what I should do?

Thanks in advance.

unSpawn 03-31-2006 06:13 AM

"An established connection was aborted by the software in your host machine."
"User-friendly" error messages don't help troubleshooting errors: it's better to post the errors from the client-side application log (window) and the server-side daemon log.

kara_lahana 03-31-2006 06:53 AM

may be you start your vsftp false. how install you your vsftp server
from sourve code or rpm dep ???

it is also posible that you have a bad connetion to your server
ping your server a long time
look it if your connecction was brocked to ftpserver

you can configure your vsftp server so that it hold the session live longer.
default it is so configureted if the connection die only for 2-3 second you have upload the file agein.

check this option in your vsftpd.conf

newuser455 03-31-2006 07:43 AM

My vsftpd log seems to be empty (/var/log/vsftpd.log). kara lahana, I compiled from source, and I do not have any line like that in my vsftpd conf file. I just added the line you gave me. I will let you know if it works. My current vsftpd.conf looks like this:



newuser455 03-31-2006 03:46 PM

Unfortunately, that did not work. I am still getting an error after a few minutes. What else should I check/do?

kara_lahana 03-31-2006 03:52 PM

what is you reson that you not install rpm or dep files of vsftp
apt-get or yum it.. man!!

feel your self like a hacker
if you insall it from source :)

kara_lahana 03-31-2006 03:53 PM

may be you arent run it as a daemon

you know how to run vsftp as daemon or init

newuser455 03-31-2006 10:23 PM

I installed using yum. I am running it with init, which should be working.. but is not.

fg711 12-11-2010 09:12 PM

I have had the same difficulties,now you solved?can you tell me,thank you !

All times are GMT -5. The time now is 08:59 AM.