LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-10-2014, 10:04 AM   #1
bennypr0fane
Member
 
Registered: Jan 2012
Location: Central Europe
Distribution: Manjaro, Kubuntu
Posts: 145

Rep: Reputation: Disabled
VNC connection fails: vino<->vinagre


Hello,
I cannot get a vnc connection to my headless PC over the home network. I'm trying to connect from Linux Mint Petra w/ Cinnamon, while the headless box has LMDE w/ Mate, I've been trying this for a while, but it hasn't worked yet unless I connect the LMDE box to a screen and enable vnc connections from its own desktop.
I have vino installed on LMDE, and I can connect to it using vinagre on the client side, but I just see a black rectangle in the vinagre screen, that's it. As soon as I make the connection, I get a pop-up that says a remote computer is trying to get access to my desktop. I don't get to allow or deny though, the pop-up just disappears if I click it, the vnc screen stays black.
Here is some output from vino:

Code:
 ~ $ /usr/lib/vino/vino-server
    ** (vino-server:4017): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-nndcZFmSrt: Verbindungsaufbau abgelehnt

    (vino-server:4017): EggSMClient-CRITICAL **: egg_sm_client_set_mode: assertion `global_client == NULL || global_client_mode == EGG_SM_CLIENT_MODE_DISABLED' failed
    25/02/2014 21:28:18 Autoprobing TCP port in (all) network interface
    25/02/2014 21:28:18 Listening IPv6://[::]:5900
    25/02/2014 21:28:18 Listening IPv4://0.0.0.0:5900
    25/02/2014 21:28:18 Autoprobing selected port 5900
    25/02/2014 21:28:18 Advertising security type: 'TLS' (18)
    25/02/2014 21:28:18 Re-binding socket to listen for VNC connections on TCP port 5900 in (all) interface
    25/02/2014 21:28:18 Listening IPv6://[::]:5900
 
Old 03-10-2014, 07:52 PM   #2
ericson007
Member
 
Registered: Sep 2004
Location: Japan
Distribution: CentOS 7.1
Posts: 735

Rep: Reputation: 154Reputation: 154
The way I understand is that you need to by default enable a connection for every connection attempt. So that means starting vino each time from that machine.

Try setting a default password for vino using

Code:
vino-password
Then restart the service and see what happens. I have not tried vino yet. I use tigervnc, so far that has not given me the issues that you describe.
 
Old 03-10-2014, 09:18 PM   #3
bennypr0fane
Member
 
Registered: Jan 2012
Location: Central Europe
Distribution: Manjaro, Kubuntu
Posts: 145

Original Poster
Rep: Reputation: Disabled
it says
Code:
vino-password: command not found
Also I don't understand how setting a password is going to make it accept connections by default if it's not accepting them without a password. could you explain that some more?
 
Old 03-10-2014, 09:34 PM   #4
ericson007
Member
 
Registered: Sep 2004
Location: Japan
Distribution: CentOS 7.1
Posts: 735

Rep: Reputation: 154Reputation: 154
Because vino has quite a few bugs and a few people on mailing lists have mentioned issues similar to yours. Many of them managed to run that command and had success connecting after that.

That is just something I thought may be worth trying.
 
1 members found this post helpful.
Old 03-11-2014, 01:04 PM   #5
Guttorm
Senior Member
 
Registered: Dec 2003
Location: Trondheim, Norway
Distribution: Debian and Ubuntu
Posts: 1,356

Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
Hi

I was also struggeling with vino on Linux Mint. Then I found this guide:

http://forums.linuxmint.com/viewtopi...f=157&t=109097

The x11vnc way workds great.
 
Old 04-02-2014, 07:42 PM   #6
bennypr0fane
Member
 
Registered: Jan 2012
Location: Central Europe
Distribution: Manjaro, Kubuntu
Posts: 145

Original Poster
Rep: Reputation: Disabled
this is incredibly frustrating.
I did what was described there (http://forums.linuxmint.com/viewtopi...f=157&t=109097), i.e. I added that line at the end of /etc/mdm/Init/Default, so now it looks like this:

Code:
#!/bin/sh
# Stolen from the debian kdm setup, aren't I sneaky
# Plus a lot of fun stuff added
#  -George

PATH=/usr/bin:$PATH
OLD_IFS=$IFS

mdmwhich () {
  COMMAND="$1"
  OUTPUT=
  IFS=:
  for dir in $PATH
  do
    if test -x "$dir/$COMMAND" ; then
      if test "x$OUTPUT" = "x" ; then
        OUTPUT="$dir/$COMMAND"
      fi
    fi
  done
  IFS=$OLD_IFS 
  echo "$OUTPUT"
}

sysresources=/etc/X11/Xresources

# merge in defaults
if [ -f "$sysresources" ]; then
    xrdb -merge "$sysresources"
fi

sysmodmap=/etc/X11/Xmodmap

XMODMAP=`mdmwhich xmodmap`
if [ "x$XMODMAP" != "x" ] ; then
  if [ -f $sysmodmap ]; then
    $XMODMAP $sysmodmap
  fi
fi

nohup x11vnc -shared -no6 -forever -nolookup -auth /var/lib/mdm/:0.Xauth -passwd ‘Test123!’ 2>/dev/null 1>&2 &

exit 0
well, nothing. I'm trying to connect vinagre, I get "connection to 10.0.0.18 was closed", not even any output in terminal. I think this system just hates me.
 
  


Reply

Tags
vnc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Vinagre 3.10 Beta 1 Implements the get_dimensions() Virtual Function for VNC/RDP LXer Syndicated Linux News 0 08-20-2013 08:03 PM
Vinagre not working with reverse VNC connections fbobraga Linux - Newbie 5 02-26-2012 12:16 PM
Unable to Connect to VNC server (vino) tiger.woods Ubuntu 1 03-08-2009 10:35 PM
LXer: Vinagre, An Excellent GNOME VNC Client LXer Syndicated Linux News 0 09-16-2007 02:11 PM
Suse 10 + VNC + Gnome: How? (vino?) WojtekO SUSE / openSUSE 2 05-05-2006 03:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration