-   Linux - Software (
-   -   VMware Workstation Error :-( (

G_Slackw 06-12-2004 10:07 PM

VMware Workstation Error :-(

First at all I'm a beginner ( I'm running Slackware 9.1 & Windows XP Pro [dual boot] but
When I try to start my VMW in my linux host I can't because of the following error

bash-2.05b# vmware

VMware Workstation Error:
Could not open /dev/vmmon: No such device.
Please make sure that the kernel module `vmmon' is loaded.

Press "Enter" to continue...

VMware Workstation Error:
Failed to initialize monitor device.

Press "Enter" to continue...

How can I load 'vmmon' module?

P4 2.6Ghz
1GHZ DDR 33M chache 7200

:newbie: :confused:

Tinkster 06-12-2004 11:02 PM

It's been a while that I mucked around with
vmware (3.1.x) but ....

Did you run
For all I know vmmon is not part of the normal
linux kernel but installed/set-up by vmware...


Cerbere 06-13-2004 01:13 AM

You're going to run into problems running the setup because Slack uses the BSD style init (as opposed to the Sys V init used by most distros). Check out the following site for a step-by-step guide for getting around this.

You may also have troubles if you're running a 2.6.* kernel. Try searching the forum for info about that, I know people have posted solutions.

--- Cerbere

TroyCoX 07-01-2004 10:15 AM

the Solution is Simple
i just install Vmware workstation 4.5.1 in my Salckware 10.0 kernel 2.6.7
i follow this how to
and before i run i open the X11 configuration and in the line
Option "omit xfree86-dga" # don't initialise the DGA extension

i put one # -> #Option "omit xfree86-dga" # don't initialise the DGA extension

and after Load "extmod"

after i run

And the party begin

macleo 07-01-2004 11:12 AM

All times are GMT -5. The time now is 04:27 PM.