LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   VMware Tools (https://www.linuxquestions.org/questions/linux-software-2/vmware-tools-367908/)

rayman1986 09-28-2005 03:05 PM

VMware Tools
 
I tried looking for answers, but I am really new to Linux and I can't seem to find an answer that is in english.

I am running Mandrake 10 on Vmware 5

I understand that I need to set my CD drive to either use an ISO or not use an ISO. I'm not sure which, everywhere I look is filled with too much jargon that I can't understand. What I need to know, is how to configure this so that I can install vmware tools.

From what I understand I should just be able to select "install vmware tools" and a cd should be mounted, then auto run with a wizard to guide me through it. Right now the CD just sits there and doesnt do anything.

Any help would be appreciated.

debianmike 09-28-2005 03:15 PM

with mandrake running, in the VMWare toolbar, click Install VMWare tools.

This will point your virtual cdrom drive to an ISO file, which will make the cdrom drive inside Mandrake seem as if a complete cdrom is loaded.

I don't know mandrake, but its possible it is not automounting.

Go to a shell and type mount....is /mnt/cdrom or /media/cdrom mounted to anything? can you cd /mnt/cdrom and see the vmware....tgz files?

if not, as root type mount /mnt/cdrom (or /media/cdrom).

Then:

tar -zxvf /mnt/cdrom/vmwarexxxxxxx.tgz -C /tmp

then

cd /tmp/vmwarexxxxx

then, in that new folder is a install.sh file so type:

./install.sh

and read the instructions.

(All from memory so i might be a little off on the vmwarexxx.tgz files.)

rayman1986 09-28-2005 03:29 PM

I went into the console and typed:

tar -zxvf /mnt/cdrom/vmware-5.0.0-13124.tar.gz -c /tmp

I assumed the x's you were typing were the numbers and such in that file. I ended up getting an error saying:

tar: you may not specify more than one `-Acdtrux' option
try `tar --help' for more information




I don't know what an "acdtrux' option is, i didn't know I was declaring more than one of them o.O

debianmike 09-28-2005 03:35 PM

its a capital C not little c

but you are right about the xxxxxxxxxxxxxx

dmellem 09-28-2005 03:36 PM

The flags are case sensitive. You're using -x to extract and -c to create and you can't do that. Change it to a capital -C and it'll change to that directory for extraction.

-Dan

rayman1986 09-28-2005 03:43 PM

Ok, I posted prematurely. I ended up getting it. I was told I need to be loged in as "root" to install, which I am sure I can figure out on my own if I nose around enough.

Thanx a lot for your help, I really appreciate it


All times are GMT -5. The time now is 04:03 PM.