LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   VMware is running extremely slow and very unresponsive on FC 23 with VMware Player 12 (https://www.linuxquestions.org/questions/linux-software-2/vmware-is-running-extremely-slow-and-very-unresponsive-on-fc-23-with-vmware-player-12-a-4175572795/)

cyberdome 02-20-2016 02:40 PM

VMware is running extremely slow and very unresponsive on FC 23 with VMware Player 12
 
Hello World,

I am running FC 23 just upgraded and just upgraded VMware player 7 to VMware Player 12. And now all my Linux VM's boxes are running extremely slow. Very unresponsive. I am not able to open a firefox browser.

I just updated VMware Tools on all VM's even including the Windoze VM's. Windoze VM's are running perfectly normal speed.

But my Fedora VM, Ubuntu VM, and OpenSuSE VM's are all running exteremely unresponsive and slow. What can I do to resolve this?

Ubuntu VM = Slow and Unresponsive
OpenSuSE VM = Slow and Unresponsive
Fedora VM = Slow and Unresponsive
Windows 8 = Normal
Second Windows = Normal


Any help is greatly appreciated. Thanks

cyberdome 02-21-2016 10:40 AM

Quote:


e have a HOST ubuntu machine running VMPlayer and vmware-vmx was eating CPU to 100% or almost 400% ( with 4 CPU configured )

After several "google searches" i seem to have found the issue is this thread:

https://communities.vmware.com/threa...rt=30&tstart=0


Just run this on terminal and the rebot host UBUNTU


vblank_mode=0 /usr/lib/vmware/bin/vmplayer

This not WORK!!!!


SOLVED:

edit the file rc.local and add the lines below....

sudo vi /etc/rc.local

if test -f /sys/kernel/mm/transparent_hugepage/enabled; then
echo never > /sys/kernel/mm/transparent_hugepage/enabled
fi
if test -f /sys/kernel/mm/transparent_hugepage/defrag; then
echo never > /sys/kernel/mm/transparent_hugepage/defrag
fi
exit 0


So, for anyone else having this issue. After much troubleshooting, I ran these commands to fix my extremely slowness issue with FC23 with VMware Player 12

Step 1 - echo never > /sys/kernel/mm/transparent_hugepage/enabled

Step 2 - echo never > /sys/kernel/mm/transparent_hugepage/defrag


Then, I rebooted all of my VM's OS environments.


For permanent, I think you have to put those lines in your rc.local file. But I don't have that file. So, I just ran the commands.

Now, All of my VM's OS are running on normal speed. Except the Fedora 23 VM OS. For some reason, it keeps complaining that VMware Tools is NOT installed. Even though I have installed it already. Fedora 23 VM is little bit slow but faster than before. So, I may have to live with it.


I do know that there is major issue with VMware Player 12 with Fedora 23. So, beware!!!


https://communities.vmware.com/threa...art=0&tstart=0

syg00 02-21-2016 06:16 PM

Changing the sysctl dynamically like that only stops new THP creation. - better to pass it to the kernel at startup via grub. That way THP are never used at all.
Add " transparent_hugepage=never" (no quotes, but include the leading blank) to the GRUB_CMDLINE_LINUX line in /etc/default/grub. Just insert it before the final double-quote.
Then from a terminal run "sudo grub2-mkconfig -o /boot/grub2/grub.cfg" and reboot.


All times are GMT -5. The time now is 11:21 AM.