LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   VMware installation error in Ubuntu (https://www.linuxquestions.org/questions/linux-software-2/vmware-installation-error-in-ubuntu-686398/)

peterha 11-26-2008 01:11 PM

VMware installation error in Ubuntu
 
I tried to install vmware server 1.0.8 in ubuntu 8.04 and -because I am a beginner with Linux- I did exactly as was described on the webpage but after installing the contents of the VMware package and accepting all the proposals for the default directories etc, the installation stopped with the message: "Unable to get access rights of source file "./vmware-vix.bin".
As I donot know what this means. I also donot see any added option to start VMware. Could anyone help me?

Acron_0248 11-26-2008 01:38 PM

Maybe a dumb question but, are you sure you're installing as root?

Are you installing using the tar.gz file from vmware or are you using apt-get to get the file from some repository?

If is the earlier, then you should use something like:
Code:

sudo /path/to/vmware-install.pl
I don't use ubuntu and don't know if they offer the installation of vmware from some repo (official or not) so the best thing you could do to help us to help you is to be a bit more specific about the steps you're performing trying to install vmware

peterha 12-02-2008 02:42 PM

trouble installing vmware in ubuntu
 
Why is it so difficult to get something installed in Linux?
My first try to install the free VMware server version was hopeless. I re-installed Ubuntu and downloaded VMware workstation, hoping that that would work.
It is a 30-day trial version and I thought maybe that is easier to install. Of my 30 days I have already spent 2 days figuring out how in heavens name to access the file or better still: how to open or install it.
First of all it was a .rpm file so after lots of searching on the Internet I found out that 1. I had to install rpm, 2. update ubuntu 3. install alien 4. transform .rpm package in .deb format 5. then install via dpkg -i vmware-workstation xxx.deb my VMware workstation.
After that was done nothing happened. No icon appeared, no message, nothing!
In a terminal window I typed: vmware -> nothing, I searched in my menubar for an installation of VMware -> nothing.
When -in a terminal window- I type: locate vmware, the answer is:

/home/proot/Documenten/vmware-workstation_6.5.1-126130_i386.deb
/usr/lib/xorg/modules/drivers/vmware_drv.so
/usr/share/app-install/icons/_usr_share_pixmaps_vmware-player.png
/usr/share/bug/xserver-xorg-video-vmware
/usr/share/bug/xserver-xorg-video-vmware/script
/usr/share/doc/vmware-workstation
/usr/share/doc/xserver-xorg-video-vmware
/usr/share/doc/vmware-workstation/changelog.Debian.gz
/usr/share/doc/vmware-workstation/copyright
/usr/share/doc/xserver-xorg-video-vmware/changelog.Debian.gz
/usr/share/doc/xserver-xorg-video-vmware/changelog.gz
/usr/share/doc/xserver-xorg-video-vmware/copyright
/usr/share/man/man4/vmware.4.gz
/usr/share/xserver-xorg/pci/vmware.ids
/var/cache/vmware
/var/cache/vmware/VMware-Workstation-6.5.1-126130.i386.bundle
/var/lib/dpkg/info/vmware-workstation.list
/var/lib/dpkg/info/vmware-workstation.md5sums
/var/lib/dpkg/info/xserver-xorg-video-vmware.list
/var/lib/dpkg/info/xserver-xorg-video-vmware.md5sums

So something has happened, but what?
Does this mean that VMware is installed, and how can I start it or ....?

I donot have any experience with Linux, I am new but I find it very difficult, so please advise.

Thanxx

Acron_0248 12-02-2008 07:04 PM

First off, not everything is hard to install on linux, there's a few programs which, based on system's current condition can be tricky but not impossible.

There's no point in using an rpm converted to deb to install vmware, the tgz file from vmware's server and maybe an extra update, should be enough.

However, since you're having to much trouble setting vmware, I recommend you to try using canonical's comercial repository to install vmware through apt-get.

Shouldn't be too dificult.

peterha 12-05-2008 01:04 PM

Thanks for the link. I followed the link and on the page in question it said that I needed to edit the sources.list file wit: sudo vi /etc/apt/sources.list.
A file opened but I had no way of editing the file. Opening it with a text-editor and trying to save the modified file I got the message that I did not have the proper rights!!! I am the only one on the computer and I log in as root, so??? :-((
On another webpage I found: sudo gedit /etc/.. With this I was able to edit and save the file. Next I updated Ubuntu and clicked on the link to install vmware. Then I got the message: the vmware-package could not be found. Again a dead end. :-((
After that I tried my already downloaded vmware server, I untarred it and installed it with: sudo ./vmware-install.pl
After a lot of questions -oh wonder- it continued where it had previously stopped the installationprocess. After completing the installation procedure it still did not work. Maybe because during the process it said something about needing a C-compiler. :-((
Again after a search on the Internet I read that I had to install: build-essential. So I did. Redone the whole installation process and it finished with the message: installation successful. I even had an icon to start it with. After choosing Applications>System Tools>VMware server console nothing happened. :-((
At the end of the installation process there was however a message saying something about libgcc_s.so.1: version gcc_3.4 not found.
Again after searching on the Internet I learned that I had to copy two files into a vmware sub-directory.
When I had done so, I was able to start VMware server and it actually worked!! :-))
Maybe some things are easy to install and apparently I have not chosen the easiest application, but Linux requires a lot of knowledge and therefore it is very hard on a Windows-to-Linux change-over.

Acron_0248 12-05-2008 04:02 PM

If you're new to the change-over, yes, it is difficult :)

As for vmware, is a tricky package not too much, but kinda, the problem increase when installing from tarball which won't get any needed dependencies for you.

Anyway, good to see you get it working, enjoy it now ;)


All times are GMT -5. The time now is 01:58 AM.