-   Linux - Software (
-   -   VMPlayer not installing in MINT 64 bit (

Uaebuntu 10-28-2011 01:06 AM

VMPlayer not installing in MINT 64 bit
I have been trying to install VMPlayer on my MINT 11 system and keep getting installer errors. I have tried various permutations of the CLI gksudo bash etc and also tried installing earlier versions of the VMplayer code.

Build-essentials are installed

jim@saturn ~ $ uname -a
Linux saturn 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
jim@saturn ~ $ sudo sh VMware-Player-3.1.5-491717.x86_64.bundle
[sudo] password for jim:
Extracting VMware Installer...done.
VMware-Player-3.1.5-491717.x86_64.bundle: line 302: /tmp/vmis.2WxO3j/install/vmware-installer/vmware-installer: Permission denied

Can anyone help here?
jim@saturn ~ $

syg00 10-28-2011 06:09 PM

Probably spawning multiple shells - google suggests "gksudo bash ..." should work.
Try that and show us if it fails.

unkn(0)wn 10-29-2011 01:09 AM


sudo su
chmod +x VMware-Player-3.1.5-491717.x86_64.bundle
works for me !

Uaebuntu 10-29-2011 02:44 PM

Hi Thanks for the response.

Ran gksudo bash

Similar response, the installer extracted then NOTHING, no error message just nothing.

Only difference was that I had installed the MINT 11 updates between tries, I had tried the same and go exactlt the same result priuor to my original post as I had looked at various other channels like Google etc (as I do before posting for help).

This one has got me stumped. I hope this response helps.

Uaebuntu 10-30-2011 12:36 PM

Tried both, still no luck
1 Attachment(s)
Thanks for replying

tried both solutions (see screen shots) and nothing worked, still get permission denied on the sudo su and the installer extracts but nothing else on the gksudo option

adamk75 10-30-2011 01:28 PM

Is /tmp on a separate partition? Is it mounted noexec?


Uaebuntu 10-31-2011 06:51 AM

I use a SSD as my system disk and keep tmp in RAM, here is the line from /etc/fstab

tmpfs /tmp tmpfs nodev,nosuid,noexec,mode=1777 0 0

Now this was recommended along with some other changes in an earlier version of ubuntu which did not support SSD the idea was for performance and to minimise unnecessary R/W to the SSD that RAM (which is abdundant) was used to host tmp. I have never had problems with this until perhaps now so have always left it as is.

adamk75 10-31-2011 06:58 AM

Well, clearly, now it's a problem :-)


Uaebuntu 10-31-2011 12:08 PM

I'll try REM ing it out
I'll stick a # in front of the line in /etc/fstab

I'm assuming if I don't do anything tmp will default to the /dev/sda1

I looked in my Ubuntu 8.04 notes (I record my changes!) the reason it is set at nodev,nosuid,noexec was as a "security" measure, so any advice on what to do if it works, I did a quick search and some people think this is a superfluous measure, however it is beyond the realms of my knowledge.

adamk75 10-31-2011 12:11 PM

Setting "noexec" on a filesystem is a valid security measure. It is not uncommon for rootkits to get dropped into directories in /tmp/.

The tradeoff (as there is always a tradeoff in security) is that valid programs that use /tmp may have problems such as this. Once you install vmware, you can always mount /tmp again with noexec.


Uaebuntu 11-01-2011 11:59 AM


Solved the problem by reming out the tmpfs line as discussed.

(and turned my super fast 64 bit Linux flying machine into an old Win XP Pro.... that's progress for you. I needed access to an old windoze programme so I'm there now.)

All times are GMT -5. The time now is 11:15 AM.