LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-16-2012, 02:00 AM   #1
Nemesissparadise
Member
 
Registered: Nov 2007
Location: North Pole Alaska
Distribution: Fedora
Posts: 137

Rep: Reputation: 15
VLC wont install


I am running Centos on my laptop but VLC wont install when i type yum install vlc I get

[root@localhost Nemesis]# yum install vlc
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: centos.arcticnetwork.ca
* epel: www.muug.mb.ca
* extras: centos.arcticnetwork.ca
* rpmforge: fr2.rpmfind.net
* updates: centos.arcticnetwork.ca
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package vlc.x86_64 0:1.1.13-1.el6.rf will be installed
--> Processing Dependency: libupnp.so.3()(64bit) for package: vlc-1.1.13-1.el6.rf.x86_64
--> Processing Dependency: libmodplug.so.0()(64bit) for package: vlc-1.1.13-1.el6.rf.x86_64
--> Processing Dependency: libthreadutil.so.2()(64bit) for package: vlc-1.1.13-1.el6.rf.x86_64
--> Finished Dependency Resolution
Error: Package: vlc-1.1.13-1.el6.rf.x86_64 (rpmforge)
Requires: libupnp.so.3()(64bit)
Available: libupnp-1.6.6-1.el6.rf.x86_64 (rpmforge)
libupnp.so.3()(64bit)
Installed: libupnp-1.6.13-1.el6.x86_64 (@epel)
Not found
Error: Package: vlc-1.1.13-1.el6.rf.x86_64 (rpmforge)
Requires: libthreadutil.so.2()(64bit)
Available: libupnp-1.6.6-1.el6.rf.x86_64 (rpmforge)
libthreadutil.so.2()(64bit)
Installed: libupnp-1.6.13-1.el6.x86_64 (@epel)
Not found
Error: Package: vlc-1.1.13-1.el6.rf.x86_64 (rpmforge)
Requires: libmodplug.so.0()(64bit)
Available: libmodplug-0.8.7-1.el6.rf.x86_64 (rpmforge)
libmodplug.so.0()(64bit)
Installed: 1:libmodplug-0.8.8.3-2.el6.x86_64 (@epel)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

If I do skip broken it installs ok but then I cant do updates for whatever reason
 
Old 02-16-2012, 11:49 PM   #2
Nemesissparadise
Member
 
Registered: Nov 2007
Location: North Pole Alaska
Distribution: Fedora
Posts: 137

Original Poster
Rep: Reputation: 15
I have done a little research and found this page... asuming this will correct it where do i stick this line?
https://www.centos.org/modules/newbb...orumpost150800

Last edited by Nemesissparadise; 02-17-2012 at 03:28 AM.
 
Old 02-17-2012, 11:49 AM   #3
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Xubuntu
Posts: 5,429

Rep: Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890
Like Andrew said, just add exclude=libmodplug to /etc/yum.repo.d/epel.repo and to /etc/yum.repo.d/epel-testing.repo.

This sort of thing is part of the repo game in CentOS. In my case, I couldn't install claws-mail until I gave EPEL priority over RPMfusion. Incidentally, have you set priorities for your repos?
 
Old 02-17-2012, 12:12 PM   #4
snowday
Senior Member
 
Registered: Feb 2009
Posts: 4,667

Rep: Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407
You must set your YUM priorities and be very, very careful when mixing 3rd-party repos like EPEL and RPM Fusion that are not supported by CentOS:

http://wiki.centos.org/AdditionalResources/Repositories
http://wiki.centos.org/PackageManagement/Yum/Priorities

Last edited by snowday; 02-17-2012 at 12:15 PM.
 
Old 02-17-2012, 10:06 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,464

Rep: Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605
if you are NOT very VERY careful with the 3d party repos and installing the video and music programs in Cent/RHEL/SL
you can VERY QUICKLY 100% mess up the install
listen to EVERY AND ALL warnings !!!!!

set up "yum-priorities"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VLC player wont install on Fedora 10 jaspreet Linux - Newbie 12 02-19-2010 09:20 AM
VLC error: VLC could not open the file "/usr/share/vlc/skins2/text.bmp". brjoon1021 Ubuntu 1 01-14-2009 11:48 PM
wireless driver wont install,ethernet wont work Reanimator Linux - Newbie 4 05-05-2008 09:22 AM
2 probs, apt-get wont download anything. blackbox wont install minibootsy Linux - Software 2 06-10-2004 02:55 AM
Suse 9, RH9 wont install properly. Mandrake 9 wont boot properly? Help. l2ich84 Linux - Newbie 1 01-31-2004 12:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration