LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-28-2009, 03:00 PM   #16
chriz9x
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Rep: Reputation: 0

Quote:
Originally Posted by MadManDeX View Post

I have the same problem ( I'm using fedora 10),
[...]
--> Missing Dependency: libass.so.3 is needed by package vlc-core-0.9.9-2.fc10.i386 (rpmfusion-free-updates)
Error: Missing Dependency: libass.so.3 is needed by package vlc-core-0.9.9-2.fc10.i386 (rpmfusion-free-updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

Another detail maybe is helpfull

locate libass.so
/usr/lib/libass.so.4
/usr/lib/libass.so.4.0.0
There seems to be an inconsistency in the repository which should be solved soon. You may read about the same issue here:
http://forums.fedoraforum.org/showthread.php?p=1269786

Using "yum --skip-broken ..." helped on my F10 system with a similar problem.
 
Old 09-29-2009, 12:51 AM   #17
lemon09
Member
 
Registered: Jun 2009
Location: kolkata,India
Distribution: Mandriva,openSuse,Mint,Debian
Posts: 285

Original Poster
Blog Entries: 1

Rep: Reputation: 37
@ MadMan

the problem is fixed.
can you post the output of
Code:
$yum repolist
i faced a lot of problem while installing it. finally i did it.
 
Old 09-29-2009, 03:02 PM   #18
rajv12
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Rep: Reputation: 0
hello,
i have the same situation with the following error msg:

[root@Raj ~]# yum repolist
Loaded plugins: refresh-packagekit
repo id repo name status
fedora Fedora 10 - i386 enabled: 11,416
rawhide Fedora - Rawhide - Developmental packages for the next Fedora release enabled: 15,071
rpmfusion-free RPM Fusion for Fedora 10 - Free enabled: 324
rpmfusion-free-rawhide RPM Fusion for Fedora Rawhide - Free enabled: 469
rpmfusion-free-updates RPM Fusion for Fedora 10 - Free - Updates enabled: 1,116
updates Fedora 10 - i386 - Updates enabled: 6,873
repolist: 35,269
[root@Raj ~]# yum install libass
Loaded plugins: refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libass = 0.9.7-1.fc10 for package: libass-devel-0.9.7-1.fc10.i386
---> Package libass.i686 0:0.9.7-1.fc12 set to be updated
--> Running transaction check
---> Package libass-devel.i686 0:0.9.7-1.fc12 set to be updated
--> Processing Dependency: pkgconfig(enca) for package: libass-devel-0.9.7-1.fc12.i686
--> Running transaction check
---> Package enca-devel.i686 0:1.10-1.fc12 set to be updated
--> Processing Dependency: enca = 1.10-1.fc12 for package: enca-devel-1.10-1.fc12.i686
--> Running transaction check
---> Package enca.i686 0:1.10-1.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================== ======================
Package Arch Version Repository Size
==================================================================================================== ======================
Updating:
libass i686 0.9.7-1.fc12 rawhide 53 k
Installing for dependencies:
enca-devel i686 1.10-1.fc12 rawhide 21 k
Updating for dependencies:
enca i686 1.10-1.fc12 rawhide 92 k
libass-devel i686 0.9.7-1.fc12 rawhide 8.1 k

Transaction Summary
==================================================================================================== ======================
Install 1 Package(s)
Update 3 Package(s)
Remove 0 Package(s)

Total download size: 175 k
Is this ok [y/N]: y
Downloading Packages:
(1/4): enca-1.10-1.fc12.i686.rpm | 92 kB 00:01
(2/4): enca-devel-1.10-1.fc12.i686.rpm | 21 kB 00:01
(3/4): libass-0.9.7-1.fc12.i686.rpm | 53 kB 00:01
(4/4): libass-devel-0.9.7-1.fc12.i686.rpm | 8.1 kB 00:00
--------------------------------------------------------------------------------------------------------------------------
Total 38 kB/s | 175 kB 00:04
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) is needed by libass-0.9.7-1.fc12.i686
rpmlib(PayloadIsXz) is needed by enca-1.10-1.fc12.i686
rpmlib(PayloadIsXz) is needed by libass-devel-0.9.7-1.fc12.i686
rpmlib(PayloadIsXz) is needed by enca-devel-1.10-1.fc12.i686
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])
 
Old 09-29-2009, 05:12 PM   #19
MadManDeX
LQ Newbie
 
Registered: Sep 2009
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by lemon09 View Post
@ MadMan

the problem is fixed.
can you post the output of
Code:
$yum repolist
i faced a lot of problem while installing it. finally i did it.
Here it is

Code:
yum repolist
Loaded plugins: refresh-packagekit
adobe-linux-i386                                                                                                                                                                                                      |  951 B     00:00
fedora                                                                                                                                                                                                                | 2.8 kB     00:00
rpmfusion-free                                                                                                                                                                                                        | 2.7 kB     00:00
rpmfusion-free-updates                                                                                                                                                                                                | 2.8 kB     00:00
rpmfusion-nonfree                                                                                                                                                                                                     | 2.7 kB     00:00
rpmfusion-nonfree-updates                                                                                                                                                                                             | 2.8 kB     00:00
updates                                                                                                                                                                                                               | 3.4 kB     00:00
updates/primary_db                                                                                                                                                                                                    | 4.5 MB     00:03
repo id                                                                                              repo name                                                                                                                status
adobe-linux-i386                                                                                     Adobe Systems Incorporated                                                                                               enabled:     17
fedora                                                                                               Fedora 10 - i386                                                                                                         enabled: 11,416
rpmfusion-free                                                                                       RPM Fusion for Fedora 10 - Free                                                                                          enabled:    324
rpmfusion-free-updates                                                                               RPM Fusion for Fedora 10 - Free - Updates                                                                                enabled:  1,116
rpmfusion-nonfree                                                                                    RPM Fusion for Fedora 10 - Nonfree                                                                                       enabled:    142
rpmfusion-nonfree-updates                                                                            RPM Fusion for Fedora 10 - Nonfree - Updates                                                                             enabled:    784
updates                                                                                              Fedora 10 - i386 - Updates                                                                                               enabled:  6,889
repolist: 20,688
 
Old 09-30-2009, 03:35 AM   #20
lemon09
Member
 
Registered: Jun 2009
Location: kolkata,India
Distribution: Mandriva,openSuse,Mint,Debian
Posts: 285

Original Poster
Blog Entries: 1

Rep: Reputation: 37
Quote:
Originally Posted by rajv12 View Post
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) is needed by libass-0.9.7-1.fc12.i686
rpmlib(PayloadIsXz) is needed by enca-1.10-1.fc12.i686
rpmlib(PayloadIsXz) is needed by libass-devel-0.9.7-1.fc12.i686
rpmlib(PayloadIsXz) is needed by enca-devel-1.10-1.fc12.i686
i think rpmlib is not installed in your system or is out of date.

try installing it separately

Code:
#yum install rpmlib
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing VLC judithbriza Linux - Newbie 16 06-18-2009 04:36 AM
problem installing VLC player in fedora 8 perky.nishi Linux - Software 7 05-12-2009 12:55 PM
VLC installation problem for fedora 9 ? r.007don Linux - Newbie 27 10-18-2008 01:38 PM
installing vlc in fedora core 6 kjan.ondrace Linux - Software 2 11-05-2006 03:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration