-   Linux - Software (
-   -   Virtualbox USB device not available to virtual machine - FC7 (

speedsrfr 09-22-2007 11:41 AM

Virtualbox USB device not available to virtual machine - FC7
Hallo everyone
Im fairly new to linux but I used to be good with DOS when it was around. After following many internet guides and a lot of tweaking i finally got Fedora Core 7 Moonshine working completely (mp3 flash java printer) etc. well almost. I want to use my scanner in Linux its a Hp Scanjet G4010.
Sane doesnt support it, so I got virtualbox and thought of using it through a Win xp pro virtual machine.

I have the vm running perfectly but I cant get it to see USB devices even though I enabled the filter for my scanner on Virtualbox 1.50. Virtualbox says the scanner is unavailable. I suspect his is cause Linux is already using it or something. I dont know how to make it available to Virtualbox. I tried turning it off and on with the vm running, its still not working, I have it plugged in the front USB port. I dont think plugging it anywhere else makes a difference.

If anyone could help I`d appreciate it.

Running a Dell 2 gb ram amd 64 Dual Core 2 GHz desktop if that helps.

speedsrfr 09-22-2007 11:46 AM

Nevermind :D solution : Run Virtualbox as root .

dracolich 09-22-2007 12:02 PM

Glad you found a workaround, but if you don't want to have to run it as root all the time, here's the workaround I found. The problem is because of udev and libusb detecting the devices. VitualBox depends on information from usbfs. If you know how to edit udev rules you can comment the "libusb device" (# in front of the 2 or 3 lines) section to let usbfs work instead of libusb.

All times are GMT -5. The time now is 03:40 PM.