-   Linux - Software (
-   -   VirtualBox cannot edit VM (

scheidel21 08-14-2009 02:15 PM

VirtualBox cannot edit VM
I have a server running some VBox VMs in headless mode, but we also use it for testing purposes too and have a couple of VM that are started from the GUI for VBox from time to time. I recently created one for Windows 7, I ran the install then realized I forgot to change the network connection type from NAT to Bridged. So I opened up the properties of this VM and tried to change it but could not save it because VirtualBox told me that I had to lower the number of CPUs that the VM had as it could not be more than 2x the number of physical processors in the machine(0) which it reported to me as 0 processors in the physical machine. I then tried to edit another VM and received the same issue. So I figure no big deal I will edit it with VBoxManage at the command line, The command to change the adapter to bridged was accepted but viewing the VM info and starting up the VM bear out that it is still NATed. So I try the hard way I edit the text file with a text editor, I save it, I boot and still I have NATed networking. I go back and open the text file and my changes I made with the text editor are not there it says it is NAT again.

I am running VirtualBox 3.0.0 on an server with a XEON quad core with the host running Debian Lenny.

Anyone have any idea how to resolve this or what is going on? I have googled a good par tof the day with no answer forthcoming.

catkin 08-14-2009 04:32 PM

The clue could be in the 0.0 part of 3.0.0 :)

The new features of any new version are likely to be buggy and multiple CPUs are new with VBox version 3. You could try 3.0.3.

scheidel21 08-14-2009 07:47 PM

I thought that a bug could be part of it so I updated to 3.0.4 and the issue is resolved.

catkin 08-15-2009 06:03 AM


Originally Posted by scheidel21 (Post 3643802)
I thought that a bug could be part of it so I updated to 3.0.4 and the issue is resolved.

Cool! I'm using 3.0.2 and it's workable but flakey. Time for 3.0.4 :)

All times are GMT -5. The time now is 09:58 PM.