LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-27-2017, 08:19 PM   #1
tauro_kpo
Member
 
Registered: Feb 2007
Distribution: Debian
Posts: 100

Rep: Reputation: 16
Question Virtual floppy drive / simulate floppy drive


Hello everyone,

I'm trying to use an old program (EMT4UNIX) that works fine with physical floppy drives, but doesn't work with floppy images or loop devices.

The message is:
Code:
not a floppy device /dev/loop5
Just to clarify, this loop device works fine outside this program, but I guess it is not a "real enough" block device and the program detects it and thus halts.

Is there some equivalent of CDEmu but for floppy drives? Any way I can fool the program to think this is actually a physical floppy drive?

By the way, if it's of any importance, I'm using Ubuntu 16.04 ATM.

Thanks.
 
Old 04-28-2017, 07:20 AM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 21,589

Rep: Reputation: 4163Reputation: 4163Reputation: 4163Reputation: 4163Reputation: 4163Reputation: 4163Reputation: 4163Reputation: 4163Reputation: 4163Reputation: 4163Reputation: 4163
At the moment the only thing I can think of that emulates a physical floppy drive is a hypervisor i.e. QEMU, Bochs or VirtualBox etc.
 
Old 04-28-2017, 08:01 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,523

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
the current linux kernels do not auto look for 3.5 in drives

you need to manually run " modprobe " AS root

for something like this i might use a KVM running rhel5 ( or CentOS 5.11 )
or if this really is a very old program a vm with rhel4


as to
Quote:
I'm trying to use an old program (EMT4UNIX) that works fine with physical floppy drives
please let us know what hardware this is that it works on
 
Old 04-28-2017, 10:03 PM   #4
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
HxC is a floppy emulator, but it's not totally virtual.
 
  


Reply

Tags
block, device, floppy, image, virtual


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Machine does not recognize floppy drive bdika Linux - Virtualization and Cloud 2 12-14-2011 03:54 PM
What is the difference between vfloppy and virtual floppy disk drive sumanch Linux - Newbie 1 05-25-2010 10:58 AM
Cannot mount my Floppy drive while creating driver floppy gobs04 Linux - Newbie 2 09-23-2009 07:43 PM
i cant open a floppy disk on a floppy drive ongpong Linux - Hardware 1 06-07-2009 10:23 PM
I need to mount a floppy drive, optical drive, jumpdrive & burning CD's. talagm SUSE / openSUSE 7 04-23-2009 05:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration