-   Linux - Software (
-   -   vim no GUI support (

seeone 09-04-2004 05:32 PM

vim no GUI support
I tried compiling vim on RH WS3 and it compiles ok (vim6.3) but even though I
used ./configure --enable -gui=auto (or even motif)
it doesn't compile with gui support.
The configure output says GUI - no support
rpm -q openmotif says it is installed.
So I tried compiling kvim using
./configure --enable-gui=kde --with-qt-dir=/usr/lib/qt-3.1/lib
and I get the same type of result.

Does anyone who has done this before have a suggestion as to what I could be doing wrong?


hw-tph 09-04-2004 07:24 PM

If you're looking to build a program against some library you will need the "devel" package corresponding to the library's package in order to build it. The devel packages contain headers and other files you will need in order to build something that uses that package. kde-<version>-devel and qt-<version>-devel might be the names, but I'm not the person to ask since I'm not that used to rpm based systems.


seeone 09-04-2004 08:58 PM

Thanks for your response. I don't think this has anything to do with rpms, as I am compiling the source files. I understand what you mean about libraries, maybe this is a PATH problem.

hw-tph 09-05-2004 05:52 AM

Well, in order to compile the source you still need to have the headers. The fact that you have a library installed doesn't mean you have the header files (from the -devel package) which are needed to compile software that use that library.

When you compile stuff that depends on a library the source will have include lines in the code. These will tell the compiler to look for header files to get information about library functionality (etc) from. These include files come with the devel packages.


sirclif 09-16-2004 11:08 AM

the gui version of vim is gvim. try downloading and compiling that

hw-tph 09-16-2004 12:21 PM

That doesn't make any sense. The vim sources are shipped in one big tarball or several smaller ones. The GTK/GTK2 GUI support known as "gvim" is enabled by passing the appropriate parameters to the configure script (i.e. ./configure --enable-gtk2-check).


sirclif 09-16-2004 05:19 PM

oh, sorry then.
you know more than i do, ive only used the version that came with my distro

jeffschwab 02-22-2010 11:09 PM

Day later, $ short, but...
For posterity: On Ubuntu, you need:

sudo aptitude install xorg-dev

It's not enough to install the GTK headers.

All times are GMT -5. The time now is 09:58 AM.