LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Video/TV (xawtv, mythtv) not working through coax (https://www.linuxquestions.org/questions/linux-software-2/video-tv-xawtv-mythtv-not-working-through-coax-246589/)

digicaf 10-24-2004 02:19 AM

Video/TV (xawtv, mythtv) not working through coax
 
Hello all,

I'm running a Debian 3.1 install and trying to get a basic PVR set up. I've got an ATI TV wonder installed and running on a Shuttle SS51G. I've had no problems getting mythtv and xawtv installed and working, but I'm having problems getting them to function properly. Basically, when I start either program, they come up ok (no errors), but I just get a blue screen. In xawtv, The menu shows me two available inputs, television (coax) and composite, which is correct. I've literally gone through every possible combination of interface configuration for the television input (NTSC us-cable, NTSC us-bcast, PAL...), but I never get anything other than the same blue screen.

Now, here's the real kicker, the composite input works fine. I can plug in any kind of device and the picture comes up beautifully. So, I feel pretty confident that I've got the v4l2 modules installed ok along with all the requisite drivers and kernel options.

I also know that the signal is good and the coax input works. I can hook the coax I'm uising into a TV and the picture comes in. I've also installed this same card in a windows box and the coax input works ok there.

considering how much work I've thrown into it, I'd hate to throw it out now :) . Can anyone help me please?

Here's the meat:

sh-2.05b$ uname -a
Linux anubis 2.6.9 #1 Sat Oct 23 23:38:29 CDT 2004 i686 GNU/Linux

sh-2.05b$ lspci | grep media
0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
0000:00:0a.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
0000:00:0a.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

sh-2.05b$ lsmod | grep bt
snd_bt87x 13384 0
bt878 11700 0
bttv 154828 1 bt878
video_buf 21636 1 bttv
firmware_class 10368 1 bttv
i2c_algo_bit 10120 1 bttv
btcx_risc 4872 1 bttv
i2c_core 23824 3 tuner,bttv,i2c_algo_bit
snd_pcm 95624 4 snd_bt87x,snd_intel8x0,snd_pcm_oss
snd_page_alloc 9992 3 snd_bt87x,snd_intel8x0,snd_pcm
snd 55780 11 snd_bt87x,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,sn d_rawmidi,snd_seq_device

sh-2.05b$ xawtv -hwscan
This is xawtv-3.94, running on Linux/i686 (2.6.9)
looking for available devices
port 56-56
type : Xvideo, image scaler
name : SIS 300/315/330 series Video Overlay

port 57-72
type : Xvideo, image scaler
name : SIS 315/330 series Video Blitter

/dev/video0: OK [ -device /dev/video0 ]
type : v4l2
name : BT878 video (ATI TV-Wonder VE)
flags: overlay capture tuner


If anyone could help me out I'd be greatly appreciative (I'd even go so far as to offer some beer to the person who can get me working) ;)


All times are GMT -5. The time now is 01:30 PM.