-   Linux - Software (
-   -   Video Playback Audio without Video xine openSUSE (

bahbahthelamb 08-23-2008 11:33 PM

Video Playback Audio without Video xine openSUSE
Just converting a friend over to the wonderful world of Linux. I use openSUSE 11 (64 bit) on my computer so I installed openSUSE 11 (32 bit) on my friend's computer. Everything is working perfectly except the video playback. I was trying to set it up close to the same way as I did mine...

add packman and vlc repositories
upgrade kaffeine (586) from packman
delete xine-lib
install libxine1 (586) from packman
install w32codec-all (586) from packman
install libdvdcss from (586) vlc

This method works for me (substituting the arch, of course), but on this computer, it is giving me audio without any picture. Tried kaffeine (preferred), dragonplayer, xine-ui, and vlc players. Only difference was vlc was able to play one mpeg (standard codec) that none of the others could. Also tried gstreamer engine (in kaffeine) with same result.

She was really looking forward to this change after falling in love with my computer, and I don't want to let her down on something as basic as video playback.

This is openSUSE 11 on Intel-based hardware, KDE4, Compiz/Emerald.

Anithen 08-24-2008 05:45 PM

I don't have much experience with xine, but maybe you can have her try mplayer. Just remember to enable gmplayer if she was looking for a xine-like experience.

For xine along with mplayer, I couldn't imaging video not playing if the codecs are installed and the video software knows where to find them.

bahbahthelamb 08-25-2008 03:29 PM

I didn't really want to try that since I've already tried multiple players and multiple rendering engines, I feel confident that another won't work whether thats mplayer, helix, or some other. I ran into another thread on a different site that said it had to do with a generic Intel driver for Linux and by switching the driver used, it should fix it. While it did not fix it completely, it did fix that one mpeg that played in vlc now plays in kaffeine/xine. This leads me to believe that it is either a different driver that the system needs (most likely), or possibly the w32codec-all doesn't work with this display adapter (don't see why, but maybe). I will have her computer back in my hands this evening and I was planing on probing to get in depth info on the display. I am used to working with nVidia and assumed that the Intel-based were a snap in comparison, but apparently that was a hasty assumption. ;)

bahbahthelamb 08-25-2008 11:55 PM

Its a Intel GMA900 GPU and it looks like there have been issues with the i810 driver on this adapter. Anyone else out there using a Intel GMA900 and can recommend a driver that has no video rendering issues?

Anithen 09-06-2008 04:59 PM

So, have you made any progress with this?

bahbahthelamb 09-09-2008 10:54 AM

I got the video playback working after changing the video driver but only with gstreamer. Lately she has mentioned that she is still having issues with it, but she's more concerned about some issue with the clipboard pasting randomly and unenvoked.

All times are GMT -5. The time now is 06:22 AM.