LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   version GLIBC_2.0 not defined in filelibc.so.6 (https://www.linuxquestions.org/questions/linux-software-2/version-glibc_2-0-not-defined-in-filelibc-so-6-a-432026/)

biogeneticmonkey 04-05-2006 12:56 PM

version GLIBC_2.0 not defined in filelibc.so.6
 
I am running SUSE 9.2 pro
When trying to start a deamon for rational robot
test agent I get the following error.

/opt/rational//bin/rtprvd: relocation error: /opt/rational//bin/rtprvd: symbol errno, version GLIBC_2.0 not defined in filelibc.so.6 with link time reference
Problems starting agent daemon,
bltlap002:/opt/rational/bin #

I know that the program is linking to the glibc_2.3 lib on the OS and the newer version does not contain the public var errno.
I need to have it run against
a GLIB2.0 but only for that program.
How do I get a GLIBC_2.0 and how do I get the program to use it ?

thank you

foo_bar_foo 04-05-2006 08:38 PM

try this if you feel like it
first get glibc 2.2.5 source
and glibc-linuxthreads 2.2.5 source
to unpack them you have to untar the glibc-linuxthreads inside the top dir of the already unpacked glibc sources.
then
Code:

mkdir ../glibc-build
cd ../glibc-build
../glibc-2.2.5/configure --prefix=/opt/glibc-2.2.5 --disable-profile --enable-add-ons --libexecdir=/opt/glibc-2.2.5/bin
echo "cross-compiling = no" > configparms
make
make install

don't know if it will compile but its worth a try
then to run it run it with a script that contains
of from a shell that you
export LD_LIBRARY_PATH=/opt/glibc-2.2.5/lib:$LD_LIBRARY_PATH

biogeneticmonkey 04-06-2006 09:25 AM

it took a while but it works !

I also found out that SUSe has a compat package you can install with YAst
serch on compat in YAst
that has old libs in it.
then you point your program to lib/i586/

but I did yours first and worked fine

very cool I really needed to get this going have a groovy day

geneticmonkey.....................


All times are GMT -5. The time now is 03:39 PM.