LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2016, 02:28 PM   #1
rayxoxo
LQ Newbie
 
Registered: Feb 2012
Location: California
Distribution: Several -Knoppix, Ubuntu, etc
Posts: 11

Rep: Reputation: Disabled
Using LM 17.3 - E: Sub-process /usr/bin/dpkg returned an error code (1)


I am very ignorant about using the terminal and as I have been trying to fix an error code(1) seem to have caused more problems while upgrading on the terminal. Here is what I think is wanted to share this problem. Any and all help would really be appreciated.

The following packages will be upgraded:
syslinux-themes-linuxmint-mate
The following partially installed packages will be configured:
nufw
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/43.6 kB of archives. After unpacking 58.4 kB will be used.
Do you want to continue? [Y/n/?]
(Reading database ... 319710 files and directories currently installed.)
Preparing to unpack .../syslinux-themes-linuxmint-mate_1.1.0_all.deb ...
Unpacking syslinux-themes-linuxmint-mate (1.1.0) over (1.0.3) ...
dpkg: error processing archive /var/cache/apt/archives/syslinux-themes-linuxmint-mate_1.1.0_all.deb (--unpack):
trying to overwrite '/usr/share/syslinux/themes/linuxmint-mate/isolinux-live/splash.png', which is also in package syslinux-themes-linuxmint-mate-petra 1.0.3
Errors were encountered while processing:
/var/cache/apt/archives/syslinux-themes-linuxmint-mate_1.1.0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up nufw (2.4.3-3) ...
Could not create certificate. Openssl output was:
Error Loading extension section v3_req
140448576648864:error:2206D06C:X509 V3 routines:X509V3_parse_list:invalid null name:v3_utl.c:326:
140448576648864:error:22097069:X509 V3 routinesO_EXT_NCONF:invalid extension string:v3_conf.c:139:name=subjectAltName,section=rayxoxo@hotmail.com,
140448576648864:error:22098080:X509 V3 routines:X509V3_EXT_nconf:error in extension:v3_conf.c:93:name=subjectAltName, value=rayxoxo@hotmail.com,
dpkg: error processing package nufw (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 
Old 05-28-2016, 03:17 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
I'm not a software upgrade expert but it looks like dpkg could not install /syslinux-themes-linuxmint-mate_1.1.0_all.deb and could not install or process the package nufw (--configure):
-::-Best to wait for a member that is good with errors and upgrading.-::-

I looked online for a little over an hour and the closest thread I could find that had a similar error message that you had was here at Ubuntu.
http://unix.stackexchange.com/questi...does-this-mean

I never use the upgrade command to upgrade to another version of a distribution.
Instead I perform a fresh installation of the distro. You may want to try that. (it's up to you)

Another thought is that if you are trying to upgrade from one distro version to another dpkg might not be able to do it's job because the sources.list isn't correct to pull from the repo of the upgraded version of the distro your trying to upgrade.

Are you trying to go from Linux Mint 17 to Linux Mint 17.3 using the dist-upgrade command? <OR> Are you just trying to upgrade Linux Mint 17.3?

Last edited by Ztcoracat; 05-28-2016 at 03:23 PM.
 
1 members found this post helpful.
Old 05-28-2016, 04:12 PM   #3
rayxoxo
LQ Newbie
 
Registered: Feb 2012
Location: California
Distribution: Several -Knoppix, Ubuntu, etc
Posts: 11

Original Poster
Rep: Reputation: Disabled
Thanks for responding Ztcoracat, I think your are right to just reinstall LM17.3. I was just thinking that I might be able to learn something from my previous errors. I have to get a thumb drive to backup this system.
Right after I do back it up, I think I'll just see if I can experiment with it prior to reinstalling.

I also, looked at a few sites to see if I could get a hint as to how to fix my screw ups. That just added to more screw ups - LOL. The system is working ok - It's just the idiot behind the curtain that messes it up every time.

I'm not sure as to how to correct the dpkg problem, but if I can remove the entire /syslinux-themes-linuxmint-mate_1.1.0_all.deb - And I think that I also caused the nufw by not installing apache correctly.

I have about 9 other computers floating around here running different distro, so it really isn't that big of a deal - My main problem is being just too lazy to read the directions. ; >)

Thanks again for the effort -
Cheers,
Ray

Last edited by rayxoxo; 05-28-2016 at 04:14 PM.
 
Old 05-28-2016, 08:32 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
You're Welcome:-

Let us know how the fresh installation goes.

https://sites.google.com/site/easylinuxtipsproject/9
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
E: Sub-process /usr/bin/dpkg returned an error code (1) nardev Linux - Software 3 04-17-2013 05:01 AM
E: Sub-process /usr/bin/dpkg returned an error code (1) Sipps123 Linux - Newbie 3 12-12-2011 12:11 AM
E: Sub-process /usr/bin/dpkg returned an error code (1) shogun1234 Linux - Software 1 05-17-2008 10:03 AM
Sub-process /usr/bin/dpkg returned an error code kako13 Debian 2 05-15-2008 07:01 PM
Sub-process /usr/bin/dpkg returned an error code (1) rapattack Debian 10 04-25-2008 12:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration