LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-02-2005, 04:16 PM   #1
Mr_Failure
LQ Newbie
 
Registered: Feb 2005
Location: Florida
Distribution: SuSE 9.2, WinXP Pro
Posts: 13

Rep: Reputation: 0
using gtkspell in gaim


I'm trying to use gtkspell in gaim and can't seem to get it working. I'm installing gaim 1.1.4 from source. I already have gtkspell installed. When I run ./configure, it says that gtkspell support is enabled. So, I run make and make install & have no problems.

When I run gaim, gtkspell doesn't seem to be operating. I get no red underlines when there's a misspelled word & I can't seem to find any menu options to enable it. I think there's something I'm missing in the configure or make steps, but there doesn't seem to be much about it through google.

The sources I'm using are:
gaim-1.1.4.tar.bz2
gtkspell-0.2.10.tar.gz
aspell-0.60.2.tar.gz

Any help would be greatly appreciated!
 
Old 03-02-2005, 05:06 PM   #2
Okie
Senior Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 1,154

Rep: Reputation: 183Reputation: 183
gtkspell works for me and i did it the same way you are doing it...

when you installed gtkspell what parameters did you use to install, it could be gaim is not seeing gtkspell when you compiled it, it usually says yes gtkspell is enabled during ./configure
 
Old 03-02-2005, 05:13 PM   #3
Mr_Failure
LQ Newbie
 
Registered: Feb 2005
Location: Florida
Distribution: SuSE 9.2, WinXP Pro
Posts: 13

Original Poster
Rep: Reputation: 0
Here's what I entered:

./configure
( gtkspell detected )
make
make install

Maybe I should try reinstalling gtkspell & aspell, but I don't know how to uninstall from a source install.
 
Old 03-02-2005, 05:34 PM   #4
Okie
Senior Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 1,154

Rep: Reputation: 183Reputation: 183
gaim probably installed to /usr/local you can go in to usr local and remove the files, then re-compile gaim again using:

./configure --prefix=/usr

then gaim should pickup & use gtkspell...
 
Old 03-02-2005, 09:50 PM   #5
Mr_Failure
LQ Newbie
 
Registered: Feb 2005
Location: Florida
Distribution: SuSE 9.2, WinXP Pro
Posts: 13

Original Poster
Rep: Reputation: 0
Hmm.. This is most unusual...

I removed gaim from /usr/local/bin, and removed gtkspell and aspell using 'make uninstall'. I then installed everything over again, using your recommendation for gaim. Again, the configure script runs correctly and says that gtkspell support is enabled. I install and run gaim, but still don't see any spell checking going on.

Is there any configuration that I need to do to aspell or gtkspell perhaps?
 
Old 03-02-2005, 09:54 PM   #6
Okie
Senior Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 1,154

Rep: Reputation: 183Reputation: 183
check the preferences, in "Conversations" > "Message Text" make sure "Highlight miss-spelled words" is ticked...
 
Old 03-03-2005, 04:50 PM   #7
Mr_Failure
LQ Newbie
 
Registered: Feb 2005
Location: Florida
Distribution: SuSE 9.2, WinXP Pro
Posts: 13

Original Poster
Rep: Reputation: 0
Ahh, I found my mistake. I didn't have the English dictionary for aspell. I installed aspell6-en-6.0-0.tar.bz2 from the aspell website, and now everything works correctly. Thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help!! errors compiling GTKspell digitalboi Linux - Software 2 12-31-2006 12:16 AM
Gaim problem with gtkspell pxy20 Linux - Software 3 05-06-2005 04:44 PM
Gaim 1.0.3 not finding gtkspell-2.0 jmoschetti45 Linux - Laptop and Netbook 2 12-02-2004 11:12 PM
GtkSpell and Gaim don't like me >_> GT_Onizuka Linux - Software 5 09-26-2004 11:02 AM
should I have gtkspell-2.0 with slack9.1 shanenin Linux - Software 1 10-17-2003 07:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration