LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   using gtkspell in gaim (https://www.linuxquestions.org/questions/linux-software-2/using-gtkspell-in-gaim-296825/)

Mr_Failure 03-02-2005 03:16 PM

using gtkspell in gaim
 
I'm trying to use gtkspell in gaim and can't seem to get it working. I'm installing gaim 1.1.4 from source. I already have gtkspell installed. When I run ./configure, it says that gtkspell support is enabled. So, I run make and make install & have no problems.

When I run gaim, gtkspell doesn't seem to be operating. I get no red underlines when there's a misspelled word & I can't seem to find any menu options to enable it. I think there's something I'm missing in the configure or make steps, but there doesn't seem to be much about it through google.

The sources I'm using are:
gaim-1.1.4.tar.bz2
gtkspell-0.2.10.tar.gz
aspell-0.60.2.tar.gz

Any help would be greatly appreciated!

Okie 03-02-2005 04:06 PM

gtkspell works for me and i did it the same way you are doing it...

when you installed gtkspell what parameters did you use to install, it could be gaim is not seeing gtkspell when you compiled it, it usually says yes gtkspell is enabled during ./configure

Mr_Failure 03-02-2005 04:13 PM

Here's what I entered:

./configure
( gtkspell detected )
make
make install

Maybe I should try reinstalling gtkspell & aspell, but I don't know how to uninstall from a source install.

Okie 03-02-2005 04:34 PM

gaim probably installed to /usr/local you can go in to usr local and remove the files, then re-compile gaim again using:

./configure --prefix=/usr

then gaim should pickup & use gtkspell...

Mr_Failure 03-02-2005 08:50 PM

Hmm.. This is most unusual...

I removed gaim from /usr/local/bin, and removed gtkspell and aspell using 'make uninstall'. I then installed everything over again, using your recommendation for gaim. Again, the configure script runs correctly and says that gtkspell support is enabled. I install and run gaim, but still don't see any spell checking going on.

Is there any configuration that I need to do to aspell or gtkspell perhaps?

Okie 03-02-2005 08:54 PM

check the preferences, in "Conversations" > "Message Text" make sure "Highlight miss-spelled words" is ticked...

Mr_Failure 03-03-2005 03:50 PM

Ahh, I found my mistake. I didn't have the English dictionary for aspell. I installed aspell6-en-6.0-0.tar.bz2 from the aspell website, and now everything works correctly. Thanks for the help!


All times are GMT -5. The time now is 12:25 PM.