LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-13-2009, 01:24 PM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 684

Rep: Reputation: 34
Using GIMP for images, but always have "blocky edges"


Look at the image in attachment, it is saved in GIMP as png.

In GIMP itself, the border already does not look smooth.
When you look at the picture, you know why I can not put this on my website...

I have tried several settings when exporting the image to png (GIMP asks to export the image before saving), and this gives the 'best' result.

How can I smooth-en my image, and particularly the border and edges ?

Do I need something in GIMP hat works in the background and gives me a higher resolution for my images ??
Attached Thumbnails
Click image for larger version

Name:	Untitled.png
Views:	19
Size:	19.2 KB
ID:	1949  
 
Old 11-13-2009, 01:33 PM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1296Reputation: 1296Reputation: 1296Reputation: 1296Reputation: 1296Reputation: 1296Reputation: 1296Reputation: 1296Reputation: 1296
Hello Jonas,

The reason why you have the borders and edges like that is because of the resolution the picture was taken. It's to low to have sharp edges. If you have a picture taken at a higher resolution, it would be bigger, but when you scale it to suit your needs, you'd keep a sharper image. If however you start with a low resolution then you cannot change it to a higher one as far as I know.

If you open an image in GIMP and go to the scaling option, you'll see a number followed by 'ppi' or so below the measurement boxes. That's the resolution the image is in. If there is an option to 'enhance' it, I stand corrected. I hope so, I'd like that too.

Kind regards,

Eric
 
Old 11-13-2009, 01:55 PM   #3
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 684

Original Poster
Rep: Reputation: 34
I don't open the image in GIMP. I open GIMP with a new file and then copy-paste the image.

Look at the image attached. I just started with a new fresh canvas and drew a circle...

So I start GIMP, File > new

It's as choppy as can be !

I do notice 72 ppi... X: 72000 Y: 72000 (advanced options)

Edit : changing this to the maximum possible does not change resolution of my circle.
Attached Thumbnails
Click image for larger version

Name:	checkthis.png
Views:	15
Size:	2.5 KB
ID:	1950  

Last edited by jonaskellens; 11-13-2009 at 01:57 PM.
 
Old 11-13-2009, 02:29 PM   #4
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Mint
Posts: 17,808

Rep: Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742
viewed on a computer monitor, a circle is always going to look like that---especially on an LCD.

Quote:
When you look at the picture, you know why I can not put this on my website...
I disagree---looks fine to me (at least at 1:1)
 
Old 11-13-2009, 03:22 PM   #5
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
Is this better ... made with inkscape.
Attached Thumbnails
Click image for larger version

Name:	drawing.png
Views:	17
Size:	28.6 KB
ID:	1952  
 
Old 11-13-2009, 03:28 PM   #6
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,339

Rep: Reputation: 231Reputation: 231Reputation: 231
you need to antialias it.
 
Old 11-14-2009, 03:32 AM   #7
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 684

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by H_TeXMeX_H View Post
Is this better ... made with inkscape.
When I open this in Firefox, it looks really great.

When copy-paste this into GIMP (even with 72ppi) it keeps looking great...
 
Old 11-14-2009, 03:36 AM   #8
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 684

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by smeezekitty View Post
you need to antialias it.
Look at picture, antialias is enabled.
Attached Thumbnails
Click image for larger version

Name:	Screenshot-1.png
Views:	12
Size:	76.7 KB
ID:	1959  
 
Old 11-14-2009, 04:21 AM   #9
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
Well then just use inkscape. I've never used GIMP for such a purpose ... making shapes or logos. I usually use GIMP for image enhancement, filters, screenshots, scaling, etc. For making logos or svg artwork use inkscape.
 
Old 11-14-2009, 04:24 AM   #10
stu7
Member
 
Registered: Jun 2007
Posts: 95

Rep: Reputation: 16
Quote:
Originally Posted by jonaskellens View Post
Look at picture, antialias is enabled.
OK then one thing everybody tried to say was_
Gimp, first thing, is a "raster" program - so, especially
for drawings like you show, this makes lines look "jagged".

But, like the other guy did... if you want something with
no jaggies at all, you need to use vector not raster.

Last edited by stu7; 11-14-2009 at 04:27 AM.
 
Old 11-14-2009, 05:15 AM   #11
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 684

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by stu7 View Post
OK then one thing everybody tried to say was_
Gimp, first thing, is a "raster" program - so, especially
for drawings like you show, this makes lines look "jagged".

But, like the other guy did... if you want something with
no jaggies at all, you need to use vector not raster.
I am using Inkscape right now and things sure look smoother. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLUTION] Slackware 13: GQview: enabling "Edit ... in the Gimp" catkin Slackware 5 09-21-2009 10:10 AM
Problem with GIMP: error "failed to fork - cannot allocate memory" heffo_j Linux - Software 5 05-24-2009 12:19 AM
LXer: DistroWatch Weekly: Solaris on the desktop, Debian edges closer to "Lenny", Sla LXer Syndicated Linux News 0 02-04-2008 05:41 AM
Compiling GIMP: "collect2: ld returned 1 exit status" linx win Debian 1 01-15-2007 12:08 AM
"Newspaper" Binary Images with Gimp kbcnetau Linux - Software 2 07-21-2004 07:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration