LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-29-2016, 11:20 AM   #1
jetberrocal
Member
 
Registered: Feb 2010
Posts: 45

Rep: Reputation: 15
Users and Groups of LXDE hangs


I am experiencing similar or same situation as https://lists.debian.org/debian-boot.../msg00002.html

Except I am not on Raspberry but on a VM.

The bug report does not tell me a work around to fix the problem, what can I do?
 
Old 11-29-2016, 04:17 PM   #2
Ratamahatta
Member
 
Registered: Feb 2012
Location: Germany
Distribution: siduction
Posts: 109

Rep: Reputation: 13
The best (as in working in most situations where graphical tools fail) would be the command line. (No need to be afraid of. It just takes practise.)

Check out useradd (or adduser), passwd and usermod. Those should do pretty much all you need. There's tons of tutorials and howtos on those, just google them.
 
Old 12-01-2016, 08:02 PM   #3
jetberrocal
Member
 
Registered: Feb 2010
Posts: 45

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Ratamahatta View Post
The best (as in working in most situations where graphical tools fail) would be the command line. (No need to be afraid of. It just takes practise.)

Check out useradd (or adduser), passwd and usermod. Those should do pretty much all you need. There's tons of tutorials and howtos on those, just google them.
I did use the command line, but I would like to fix the gui tool. Reset any corrupted files required by the app, or even reinstall the app. But I do not know the true application name so that I could go by the terminal and try to do any of those things.
 
Old 12-02-2016, 01:17 PM   #4
Ratamahatta
Member
 
Registered: Feb 2012
Location: Germany
Distribution: siduction
Posts: 109

Rep: Reputation: 13
Then you might want to open up a graphical terminal (after a fresh boot or login so there is no hanging gui tool around), type
Code:
ps axwww
then start the gui tool and then again type
Code:
ps axwww
and see what new process started. The www part of the command should make sure all command line parameters are listed. Then you can call it from the terminal and see if there are more error messages or search for bugs (or bugfixes, respectively) for that program in the internet.
 
1 members found this post helpful.
Old 12-08-2016, 11:43 AM   #5
jetberrocal
Member
 
Registered: Feb 2010
Posts: 45

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Ratamahatta View Post
Then you might want to open up a graphical terminal (after a fresh boot or login so there is no hanging gui tool around), type
Code:
ps axwww
then start the gui tool and then again type
Code:
ps axwww
and see what new process started. The www part of the command should make sure all command line parameters are listed. Then you can call it from the terminal and see if there are more error messages or search for bugs (or bugfixes, respectively) for that program in the internet.
Finally, I could login and did your command.

The application that is run seems to be:
Code:
 15056 ?        S      0:00 /usr/bin/perl /usr/share/system-tools-backends-2.0/scripts/SystemToolsBackends.pl -m Platform
 15063 ?        S      0:00 /usr/bin/perl /usr/share/system-tools-backends-2.0/scripts/SystemToolsBackends.pl -m GroupsConfig
 15064 ?        S      0:00 /usr/bin/perl /usr/share/system-tools-backends-2.0/scripts/SystemToolsBackends.pl -m UsersConfig
I tried to run them in terminal but it does not show any output, actually it sits in the terminal window without showing any following prompt.

Last edited by jetberrocal; 12-08-2016 at 12:00 PM.
 
Old 12-08-2016, 12:16 PM   #6
jetberrocal
Member
 
Registered: Feb 2010
Posts: 45

Original Poster
Rep: Reputation: 15
Found this link and seems helpfull:
https://wiki.ubuntu.com/DebuggingGnomeSystemTools

I generated the stb-users.log file:

Code:
sys::begin::Start of work report.
info::file_locate_tool_success::Found tool [uname].
info::file_run_pipe_success::Piping command [LC_ALL=C /bin/uname -s 2> /dev/null |] for reading.
info::file_locate_tool_success::Found tool [usermod].
info::file_locate_tool_success::Found tool [userdel].
info::file_locate_tool_success::Found tool [useradd].
info::file_locate_tool_success::Found tool [adduser].
info::file_locate_tool_success::Found tool [deluser].
info::file_locate_tool_success::Found tool [chfn].
warn::file_locate_tool_failed::Couldn't find tool [pw].
info::file_locate_tool_success::Found tool [passwd].
info::file_locate_tool_success::Found tool [chpasswd].
info::file_open_read_success::Reading options from [/etc/login.defs].
info::file_open_read_success::Reading options from [/etc/passwd].
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S root 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S daemon 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S bin 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S sys 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S sync 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S games 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S man 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S lp 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S mail 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S news 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S uucp 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S proxy 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S www-data 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S backup 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S list 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S irc 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S gnats 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S nobody 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S systemd-timesync 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S systemd-network 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S systemd-resolve 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S systemd-bus-proxy 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S messagebus 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S avahi 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S Debian-exim 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S statd 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S colord 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S geoclue 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S speech-dispatcher 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S pulse 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S rtkit 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S saned 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S usbmux 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S lightdm 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S debadmin 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S ntp 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S mysql 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S e2guardian 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /usr/bin/passwd -S sshd 2> /dev/null |] for reading.
info::file_open_read_success::Reading options from [/etc/shells].
warn::file_locate_tool_failed::Couldn't find tool [mount.ecryptfs].
For stb-groups.log:

Code:
sys::begin::Start of work report.
info::file_locate_tool_success::Found tool [uname].
info::file_run_pipe_success::Piping command [LC_ALL=C /bin/uname -s 2> /dev/null |] for reading.
info::file_locate_tool_success::Found tool [groupdel].
info::file_locate_tool_success::Found tool [groupadd].
info::file_locate_tool_success::Found tool [groupmod].
info::file_locate_tool_success::Found tool [delgroup].
info::file_locate_tool_success::Found tool [addgroup].
info::file_locate_tool_success::Found tool [usermod].
info::file_locate_tool_success::Found tool [gpasswd].
warn::file_locate_tool_failed::Couldn't find tool [pw].
info::file_locate_tool_success::Found tool [userdel].
info::file_locate_tool_success::Found tool [useradd].
info::file_locate_tool_success::Found tool [adduser].
info::file_locate_tool_success::Found tool [deluser].
info::file_locate_tool_success::Found tool [chfn].
info::file_locate_tool_success::Found tool [passwd].
info::file_locate_tool_success::Found tool [chpasswd].
info::file_open_read_success::Reading options from [/etc/group].
info::file_open_read_success::Reading options from [/etc/login.defs].
For Platform (stb-platform.log):

Code:
sys::begin::Start of work report.
info::file_locate_tool_success::Found tool [uname].
info::file_run_pipe_success::Piping command [LC_ALL=C /bin/uname -s 2> /dev/null |] for reading.
info::file_run_pipe_success::Piping command [LC_ALL=C /bin/uname -s 2> /dev/null |] for reading.
info::parse_sh::Getting shell option [DISTRIB_ID] from [/etc/lsb-release].
info::parse_split::Getting option [DISTRIB_ID] from [/etc/lsb-release].
warn::file_open_read_failed::Could not open [/etc/lsb-release] for reading.
info::parse_sh::Getting shell option [DISTRIB_RELEASE] from [/etc/lsb-release].
info::parse_split::Getting option [DISTRIB_RELEASE] from [/etc/lsb-release].
warn::file_open_read_failed::Could not open [/etc/lsb-release] for reading.
sys::platform_success::Configuring for platform [debian] ().
info::replace_line_first::Replacing contents of file [//var/cache/system-tools-backends/detected-platform].
info::file_open_write_success::Writing to [/var/cache/system-tools-backends/detected-platform].
info::file_create_path::Directory [/var/cache/system-tools-backends/detected-platform] created.
info::file_create_path::Directory [//var/cache/system-tools-backends/backup///1/] created.
info::file_backup_rotate::Backup directory [//var/cache/system-tools-backends/backup//] was rotated.

Last edited by jetberrocal; 12-08-2016 at 02:37 PM. Reason: Added informatioin
 
Old 12-08-2016, 04:48 PM   #7
Ratamahatta
Member
 
Registered: Feb 2012
Location: Germany
Distribution: siduction
Posts: 109

Rep: Reputation: 13
Ok, "pw" and "mount.ecryptfs" couldn't be found. I'm not sure but you might want to try to install those.
You wrote VM and posted a mail from a Debian list. Are you on Debian? Some *buntu? There is a package named "lsb-release" (in the Debian Sid repos). Maybe that can generate the /etc/lsb-release file (some apps seem to rely on it, according to the little bits I've read).
I'm afraid I can't see anything else that feels suspicious in those logs.
 
Old 12-08-2016, 05:17 PM   #8
jetberrocal
Member
 
Registered: Feb 2010
Posts: 45

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Ratamahatta View Post
Ok, "pw" and "mount.ecryptfs" couldn't be found. I'm not sure but you might want to try to install those.
You wrote VM and posted a mail from a Debian list. Are you on Debian? Some *buntu? There is a package named "lsb-release" (in the Debian Sid repos). Maybe that can generate the /etc/lsb-release file (some apps seem to rely on it, according to the little bits I've read).
I'm afraid I can't see anything else that feels suspicious in those logs.
I think the pw is not needed as it found passwd. The mount.ecryptfs line is also a warning, but I guess can try to install it anyway. Also lsb-release is not found but the value used for the platform is correct as I am at Debian system, I can install it and no harm will be caused.

I will try and post back. I am having trouble login in the system to a GUI enabled console (the keyboard keys are being repeated at login thus the password is difficult to enter) so it may take me some time to be able to try running the application after I do the install. I can login within ssh console without problem.
 
Old 12-08-2016, 06:13 PM   #9
jetberrocal
Member
 
Registered: Feb 2010
Posts: 45

Original Poster
Rep: Reputation: 15
I installed ecryptfs and now mount.ecryptfs is found.

Looked to installed lsb-release and found it was already installed according to Synaptic Packager Manager, anyway reinstalled it but still the /etc/lsb-release file is not found. I guess debian package does not use the file. According to this it should not need it: https://bugs.debian.org/cgi-bin/bugr...cgi?bug=444678

Looked to installed the pw command but it seems this command is related to FreeBSD linux flavor.

Still the application opens but gets stuck.

Last edited by jetberrocal; 12-08-2016 at 06:26 PM. Reason: Added information
 
Old 12-10-2016, 05:40 AM   #10
Ratamahatta
Member
 
Registered: Feb 2012
Location: Germany
Distribution: siduction
Posts: 109

Rep: Reputation: 13
Quote:
Originally Posted by jetberrocal View Post
Looked to installed lsb-release and found it was already installed according to Synaptic Packager Manager, anyway reinstalled it but still the /etc/lsb-release file is not found.
Same here. The file is /etc/os-release. So there is no way it could find /etc/lsb-release. (And it's a symlink which may be another thing to consider.) But the contents are very different from other distributions as described here.
Quote:
Originally Posted by jetberrocal View Post
I guess debian package does not use the file. According to this it should not need it: https://bugs.debian.org/cgi-bin/bugr...cgi?bug=444678
That's one of the first pages I read on lsb-release. It's from 2007. The link I just gave above is from 2009. So they're both ancient, really. A lot of things may (or may not) have changed since then. I don't know if there's any consensus yet.

I was trying to follow the warnings given in the log files. So if that doesn't help I'm out of ideas. Sorry.

PS: If you have a Linux machine you could open a graphical terminal and use
Code:
ssh -X
to login and have any graphical output show up on the machine you're logging in from. (I think on Windows you can use putty and configure the graphical output to be forwarded to your Windows machine. You will need to have Xming installed and running for that.)

PPS: BSD and its variants are Unix, not Linux. (Main difference: Linux can do pretty much anything, though sometimes very slow. Unix tends to do the things it can do faster, but it can't do quite as much.)

Last edited by Ratamahatta; 12-10-2016 at 05:49 AM. Reason: added more info
 
Old 12-10-2016, 10:46 PM   #11
Jjanel
Member
 
Registered: Jun 2016
Distribution: any&all, in VBox; Ol'UnixCLI; NO GUI resources
Posts: 999
Blog Entries: 12

Rep: Reputation: 361Reputation: 361Reputation: 361Reputation: 361
A few semi-random debugging ideas/'theory' (from an old Unix-CLI *but non-GUI!* 'er):
{s,l}trace [-fop] is super-cool! (research why process is in 'S' state: ps axlww;pstree)
It'd be nice to know more specifics on what package & [preceding] files are involved.
(parent of SystemToolsBackends.pl? It might not be the 'real cause'!)
Selecting the optimum web-search keywords can be tricky: I hit: a? b? c? d?

Then there's always debugging [breakpointing/single-stepping] the SOURCE CODE!

Finding&using that stb is impressive! (tho Idk ... run just 1st&post users-admin.log?)

Best wishes! (I hope this is a FUN-learning-puzzle [&not frustration] for you!)

Last edited by Jjanel; 12-10-2016 at 11:26 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
all users and groups vidyasagar6 Linux - Server 1 12-04-2012 07:46 AM
[SOLVED] samba : how to synchronize AD users & groups with Samba users &groups zelycorn Red Hat 5 05-12-2011 10:15 AM
Users and Groups ari5 Programming 3 06-07-2009 07:32 AM
System Groups from Users and Groups measekite Linux - General 3 05-05-2009 10:22 PM
What are users and what are groups? harisund Linux - Newbie 5 12-06-2005 01:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration