LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-24-2016, 03:45 AM   #1
salehm70
LQ Newbie
 
Registered: Dec 2014
Posts: 3

Rep: Reputation: Disabled
user brewbuilder does not exist - using root


Hello,
My system is REHL5 linux and working properly but when i am trying to install a package of GCC (gcc-4.1.1-52.el5.src.rpm ) or any package the warning message is appear and the package is not installed, the procedure of installing is listed below, please help me to solve the problem.

The procedure:
1- Login as a root
2- rpm -ivh gcc-4.1.1-52.el5.src.rpm

warning: gcc-4.1.1-52.el5.src.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
1:gcc warning: user brewbuilder does not exist - using root
warning: group brewbuilder does not exist - using root
warning: user brewbuilder does not exist - using root
warning: group brewbuilder does not exist - using root
########################################### [100%]
warning: user brewbuilder does not exist - using root
warning: group brewbuilder does not exist - using root
warning: user brewbuilder does not exist - using root
warning: group brewbuilder does not exist - using root
warning: user brewbuilder does not exist - using root
warning: group brewbuilder does not exist - using root
warning: user brewbuilder does not exist - using root
warning: group brewbuilder does not exist - using root
warning: user brewbuilder does not exist - using root
 
Old 07-24-2016, 03:59 AM   #2
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 3,945
Blog Entries: 11

Rep: Reputation: 2176Reputation: 2176Reputation: 2176Reputation: 2176Reputation: 2176Reputation: 2176Reputation: 2176Reputation: 2176Reputation: 2176Reputation: 2176Reputation: 2176
First, this is a source rpm, not a binary. Did you intend to build the binary locally? If not, then don't use this package. Get the binary package directly. Most RedHat users use yum to do this rather than downloading a package from somewhere and then using rpm. It's easier and safer.

If you do want to build locally, you will need to use rpmbuild --rebuild packagename. And you'd better create the brewbuilder user and group first: then you won't get those warnings. But in any case the reason the package wasn't installed is because it is a source package. That has nothing to do with the warnings.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sensible-mda: User(root) does not exist! bartoszx Linux - Server 1 11-11-2010 03:35 AM
user root does not exist (Cygwin) homer_3 Linux - General 1 07-30-2009 01:39 AM
user vincent does not exist - using root? dr_zayus69 Linux - Software 1 12-22-2004 05:39 PM
error message: user <username> does exist, using root feetyouwell Linux - Software 3 01-10-2004 02:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration