LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-04-2006, 12:13 PM   #1
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Rep: Reputation: 15
USB - I want to mount it (not automattically)


Hello,

I have Fedora Core 5. I've plugged a usb drive in and it mounts automatically and umounts all by itself. Can someone tell me please how to stop that. I want to do this for practise and get used to using linux.

When i type mount here's what it says:

automount(pid1750)on /net type autofs (rw,fd=4,pgrp=1750, minproto=2, maxproto=4) /dev/sda1 on /media/disk type vfat (rw, noexec, nosuid, nodev, shortname=winnt,uid=500)

Does that miniproto and maxproto refer to the time the usb stick is allowed to be plugged in?

Thanks for your help.

Michshelly
 
Old 08-04-2006, 12:24 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 272Reputation: 272Reputation: 272
No idea. But you might try editing the /etc/fstab file and on the line for /dev/sda1 add noauto to the options column.
 
Old 08-04-2006, 12:38 PM   #3
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Hello pljvaldez

I managed to put noauto in the line by typing vi /proc/mounts

The only the is this file is a read only. I shall find out to edit this read-only file and hopefully this will stop the USB stick from automatically mounting and hopefully some others may have answered by then if we are in correct.

Thanks again for your help.

michshelly
 
Old 08-04-2006, 12:46 PM   #4
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 272Reputation: 272Reputation: 272
I don't think that you're supposed to edit stuff in /proc because those are currently running process information, IIRC. /etc/fstab should be the file or try man automount to see if there's another config file.
 
Old 08-04-2006, 04:55 PM   #5
AdaHacker
Member
 
Registered: Oct 2001
Location: Brockport, NY
Distribution: Kubuntu
Posts: 384

Rep: Reputation: 31
Quote:
Originally Posted by michshelly
Does that miniproto and maxproto refer to the time the usb stick is allowed to be plugged in?
No, it doesn't. Those are for the automount line, which is not related to your USB stick.

Quote:
Originally Posted by pljvaldez
But you might try editing the /etc/fstab file and on the line for /dev/sda1 add noauto to the options column.
You might try it, but it won't work. I've said it before and I'll say it again: the noauto option has nothing to do with automatic mounting. If you don't believe me, just read the man page for mount. The only thing setting the noauto option flag on a device in /etc/fstab will do is prevent it from mounting on boot. If you don't insert the device until after the system is booted, then this option doesn't do anything.

On modern Linux distributions, automounting when a device is inserted is handled by a volume manager like gnome-volume-manager, ivman, or KDE's storage media manager. Your volume manager should have some settings to adjust what actions are taken when a device is inserted. I don't know anything about the gnome-volume-manager, but I can offer specifics on KDE if you're using that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 07:16 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 1 12-24-2005 04:25 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 02:15 AM
How to set WEP key automattically? enemorales Linux - Wireless Networking 2 11-24-2004 02:03 PM
mount usb module then mount usb hard drive guanyu Linux - Hardware 1 10-08-2003 11:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration