LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Upgrading <RealPlayer|HelixPlayer>? (https://www.linuxquestions.org/questions/linux-software-2/upgrading-realplayer%7Chelixplayer-760497/)

felixk 10-08-2009 03:48 AM

Upgrading <RealPlayer|HelixPlayer>?
 
Currently, I have "RealPlayer 10.0.7.785 for Linux" correctly installed.

It no longer works since upgrading my OS to Debian Lenny.

The latest version of RealPlayer (RealPlayer11GOLD.deb) needs an "lsb package >= 3.1". The question is "which one"? The number of available packages is lengthy (I can supply the list if needed). The current setup (output of "dpkg -l) is:

un lsb <none> (no description available)

ii lsb-base 3.2-20 Linux Standard Base 3.2 init script functionality

un lsb-core <none> (no description available)

ii lsb-release 3.2-20 Linux Standard Base version reporting utility

un lsb-rpm <none> (no description available)

But there are lots more (according to "aptitude search").

All advice will be gratefully received.

Felix

highfructose327 10-08-2009 07:25 AM

Have you just tried
Quote:

sudo aptitude install lsb
all of those packages may be a part of the bigger package "lsb", good luck.

felixk 10-08-2009 11:43 PM

Upgrading <RealPlayer|HelixPlayer>?
 
Quote:

Originally Posted by highfructose327 (Post 3712165)
Have you just tried all of those packages may be a part of the bigger package "lsb", good luck.

Spot-on!

Since "aptitude install" give you the choice of whether to complete the install or cancel it, I tried my luck. It turned out that the "lsb" package also installed 14 other packages (some lsb packages and some library files).

And the RealPlayer11Gold install then went to completion without further complaints.

Thank you for the prompt advice.

Felix


All times are GMT -5. The time now is 11:39 PM.