-   Linux - Software (
-   -   Upgrade to 10.04 wrong fs type (

mwjones 06-19-2010 09:53 AM

Upgrade to 10.04 wrong fs type
Just upgraded from 9.10 to 10.04 and cannot mount one of my partitions. It is encrypted/decrypted in the following fashion:


# dd if=/dev/random bs=4k count=1 | gpg -a --cipher-algo AES256 -c - > /mnt/usb/keys/fs.gpg
# gpg -q -o - /mnt/usb/keys/fs.gpg | cryptsetup -v -h sha512 -c aes-xts-plain -s 512 create crypto /dev/md1
# mkfs.ext4 /dev/mapper/crypto
# mount /dev/mapper/crypto /crypto

It has been this way for a long time, survived several release upgrades. Now when I decrypt it, I have to use gpg in one command to decrypt the key to a file, then use cat in a second command to pipe to cryptsetup, as such:


# gpg -q /mnt/usb/keys/fs.gpg
# cat /mnt/usb/keys/fs | cryptsetup -v -h sha512 -c aes-xts-plain -s 512 create crypto /dev/md1

Ok a pain, but no big deal. However, I can no longer mount the device:


# mount /dev/mapper/crypto /store/
mount: you must specify the filesystem type

This is how it's always been mounted. Well I know it's ext4, so I supplied that and was greeted with:


# mount -t ext4 /dev/mapper/crypto /store/
mount: wrong fs type, bad option, bad superblock on /dev/mapper/crypto,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

The only item in dmesg is:


[  78.212761] EXT4-fs (dm-0): VFS: Can't find ext4 filesystem
What's the deal? How do I fix this?

mwjones 06-19-2010 10:34 AM

8.10 works fine
I have a netbook running 8.10 and an external hdd that is used for backup and encrypted/decrypted in the same manner. Plugging the external hdd into the netbook, the normal decryption process on the external hdd worked fine. So to me that indicates that something changed in 10.04 causing this to be an issue, as there were no issues with 8.10 and 9.10.

How can I narrow down the root cause?

mwjones 06-21-2010 09:44 AM

I decided to wipe the drives and restore from backups. This time, though, I used the -d option in cryptsetup. FML.

All times are GMT -5. The time now is 07:02 PM.