-   Linux - Software (
-   -   updated kde now can't start x (

h00ligan 02-28-2004 08:38 PM

updated kde now can't start x
I ran rpm -Uvh --nodeps --force *.rpm as suggested in another thread with all the packages provided by suse..

It seemed to update.. things registerred as 3.2 BUT

When I restarted, in runlevel 5, it didn't boot to the gui login.. and when i logged in and ran startx I received an error stating, XIO : fatal IO error 104 (connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.

When I run startkde the following comes up.

xsetroot : unable to open display ''
xset: unable to open display ""
ksplash: cannot connect to xserver
kdeinit : Aborting. $DISPLAY is not set
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts
startkde :Done.

Any thought or do i have to reinstall.. the thought is when stuff like this breaks it's an opportuinity to learn.. so i would appreciate any insight.

Nearest I can figure, something is screwed with my display entry in the XFree86config file.. but it all looks ok to me.

Thanks for your help.

Redeye2 02-28-2004 08:51 PM

Are you using the nvidia driver? if so, you'll have to rerun the setup.

h00ligan 02-28-2004 08:54 PM

no i shouldn't be, this is in a thinkpad t20 with savage IX chipset..

how could i rerun the setup from a command line.. sorry, newb

quatsch 02-28-2004 09:51 PM

startkde is no good. Use
to see the error messages (startkde needs X running already; startx will start X and then start the default gui).

h00ligan 02-28-2004 10:20 PM

yah, sorry it was a long post.. if you check the top part the error messageis listed when i try to run startx


rmanocha 02-29-2004 12:52 AM

do you have a .xinitrc file in your home directory.
seems like that is missing
put a file ~/.xinitrc with startkde in it.
so ~/.xinitrc should look like:

that should work.It did(And still does) work for me.:D

Mr.Ampersand() 03-09-2004 08:39 AM

Similar problem like yours. (Just installed Debian Linux)
Hi I just installed Debian linux and $display doesnt want to work for me for some reason. And I cant start X Server and am thrown back in the Shell.

Here is the error I wrote down:

xsetroot unable to open display
ksplash cannot connect to X server
Aborting $display is not set

How do I set it?
I'm going to try those commands above




to see what happens. Maybe that will work

All times are GMT -5. The time now is 09:53 PM.