Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-23-2010, 05:54 PM   #1
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
Updated glib to 2.26.0, but it still reports as 2.18.4?

I'm trying to install the dependency, webkit, for Handbrake. It gave me this error:

checking for GLIB... configure: error: Package requirements (glib-2.0 >= 2.21.3
gobject-2.0 >= 2.0
gthread-2.0 >= 2.0) were not met:

Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.18.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
So I downloaded and installed glib 2.26.0. I ran ldconfig manually, tried rebooting the computer. I tried uninstalling and reinstalling glib, but it still gives me this error above.

How can I solve this dependency problem?
Old 10-24-2010, 04:56 PM   #2
LQ Guru
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,354

Rep: Reputation: 1710Reputation: 1710Reputation: 1710Reputation: 1710Reputation: 1710Reputation: 1710Reputation: 1710Reputation: 1710Reputation: 1710Reputation: 1710Reputation: 1710

Change the PKG_CONFIG_PATH accordingly. If you have installed glib-2.0 in the default /usr/local/lib/glib-2.0, you have to use
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH
before running the ./configure of the software you're trying to install.
Also you can add /usr/local/lib in the 1st line of /etc/, prior running ldconfig



dependency, glib, webkit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cent OS GLib 2.12.3 pkg-config --modversion glib-2.0' returned 2.22.2 Styles Linux - Distributions 1 10-09-2009 04:12 AM
'pkg-config --modversion glib-2.0' returned 2.16.3, but GLIB (2.14.6) pgb205 Linux - Software 7 05-17-2008 04:21 PM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
Two issues: groff not working properly and updated glib being installed not noticed.. EnigmaX Linux - General 0 08-08-2004 07:58 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:08 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration