LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   update went wrong, now can't update (https://www.linuxquestions.org/questions/linux-software-2/update-went-wrong-now-cant-update-4175422364/)

Pedroski 08-16-2012 03:52 AM

update went wrong, now can't update
 
Hi, I was using Ubuntu this morning, I ran the update manager, and left the computer to do its thing. When I came back, the update manager was stuck in the middle of 'updating triggers'. It was unresponsive. I killed it, and rebooted. Now I can't update.
I tried
sudo apt-get update
sudo apt-get clean
sudo apt-get purge but I just get 'can't get a lock on /var/apt/lock (I think it was), and another file in dkpg.

Any tips on how to unlock it, so that apt-get can get a lock. There is no other program running which should lock those files.

TobiSGD 08-16-2012 04:33 AM

Processes that use the APT system usually create a file /var/apt/lock to prevent other processes from using APT at the same time. Usually they remove that file when they exit, but since you had to kill the Update Manager this didn't happen. Just delete that file and try it again.

cynwulf 08-16-2012 04:45 AM

update manager is pure crap - get rid of it. There are only two reliable methods to perform every day updates on a Debian/APT based system:
Code:

# aptitude update && aptitude safe-upgrade
Code:

# apt-get update && apt-get upgrade
If you really can't make do without a gui, then use synaptic to apply updates.

Pedroski 08-16-2012 07:19 AM

Thanks! Sounds a bit drastic, update manager has always worked well for me until today. Anyone can have a bad day!!

As it happens, I switched to Fedora for the afternoon, then, on rebooting Ubuntu, the update manager had magically fixed itself, so I didn't even have to rm /var/apt/lock

Thanks for the tips!


All times are GMT -5. The time now is 01:50 AM.