LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-19-2005, 08:59 PM   #1
BeaverusIV
Member
 
Registered: Oct 2004
Location: New Zealand
Distribution: Arch Linux 2010.05
Posts: 136

Rep: Reputation: 18
Uninstalling glib


*** 'pkg-config --modversion glib-2.0' returned 2.8.0, but GLIB (2.6.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

this what i get when i want to install pygtk or atk or expat. I know I have glib-2.8.0 'cause I installed it, but how do I get rid of the other version?
(yes i ran ldconfig, and my LD_LIBRARY_PATH is blank)
 
Old 09-20-2005, 04:36 PM   #2
falojah
LQ Newbie
 
Registered: Sep 2005
Posts: 11

Rep: Reputation: 0
looking so hard problem so no body can answer it!
I hope my problem to be easier!
 
Old 02-25-2006, 10:39 AM   #3
mr_demilord
Member
 
Registered: Sep 2005
Posts: 244

Rep: Reputation: 30
Do you have pkg-config installed?
 
Old 03-08-2006, 08:44 PM   #4
kahlil88
Member
 
Registered: May 2005
Location: Mendocino, CA
Distribution: Arch Linux
Posts: 172

Rep: Reputation: 30
Unhappy

I'm having this problem too, when I try to compile GTK+ 2.8.13
Quote:
checking for GLIB - version >= 2.8.5...
*** 'pkg-config --modversion glib-2.0' returned 2.8.6, but GLIB (2.9.2)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.8.5 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.
GLIB 2.8.6 is already installed, and I guess it wants me to remove version 2.9.2 but I don't know how to do this.

Last edited by kahlil88; 03-08-2006 at 08:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pkg-config and glib: Uninstalling Old and Installing New CooManChu Linux - Software 6 09-06-2005 04:35 PM
Uninstalling glib 2.6.0 tommygoober Linux - Software 3 02-28-2005 12:43 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Difficult with Dependencies for the GIMP and uninstalling previous version of GLIB harryman100 Linux - Software 0 03-25-2004 03:42 AM
Uninstalling glib warkrime Linux - Newbie 4 07-16-2003 01:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration