LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-25-2008, 04:27 AM   #1
msivasakthi
LQ Newbie
 
Registered: Mar 2007
Location: India
Distribution: FC5
Posts: 17

Rep: Reputation: 0
Unhandled MIME type: 'application/octet-stream'


Hi all,

When I tried to open PDF file format in firefox web browser, it shows the error of "Unhandled MIME type: 'application/octet-stream".

why that error was produced? how can i eliminate that?

i have used Linux(FC5) box and firefox version of 1.5.0.12



Thanks,
 
Old 07-03-2008, 11:10 AM   #2
kuitang
Member
 
Registered: Sep 2005
Distribution: Slackware, Ubuntu, OS X
Posts: 58

Rep: Reputation: 15
That's the server's fault; the server said the file is application/octet-stream (meaning any generic binary file) instead of the more specific application/pdf. Just save the file as a PDF and view it locally.
 
Old 06-01-2009, 09:14 PM   #3
crazylyle
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Rep: Reputation: 0
It's file access permissions

I have two "exact" same systems -- one at work and one at home.
The system at work will open PDF files with evince fine; the one
at home generates the "Unhandled MIME type: application/octet-stream" error message.

The evince binaries that I have are the same -- eVince Document Viewer 2.20.2. From other web sites, it seems there are data files that evince uses:

> ls -l /etc/mime*
-rw-r--r-- 1 root 14148 Jul 10 2007 /etc/mime.types

and /usr/share/mime. The contents of these directories at home
and at work appear the same, but at home the protections are
just -rw-r----- while at work they are -rw-r--r--
The files are owned and grouped by root.

So I changed the protections of the files at home to 644:

chmod a+r /usr/share/mime/XMLnamespaces
chmod a+r /usr/share/mime/aliases
chmod a+r /usr/share/mime/globs
chmod a+r /usr/share/mime/magic
chmod a+r /usr/share/mime/mime.cache
chmod a+r /usr/share/mime/subclasses

and now evince works at home also.

There are a bunch of other files in this directory too, and
I expect that to be useful they would need to be readable too,
so I will do the following:

> find /usr/share/mime -type f -exec chmod a+r '{}' \;

just to make sure that everything is readable.

jim
 
Old 11-28-2010, 12:28 PM   #4
ravendawson
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Rep: Reputation: 0
thanks crazylyle, your post was helpful. I initially thought it's got to do with file extension associations in the registry after reading this article about mime application/octet-stream. The concept was far from what I initially thought...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not find mime type, application/octet-stream yyarin Linux - Desktop 0 05-17-2007 08:23 PM
Could not find mime type application/octet-stream jon rouse Mandriva 11 02-14-2007 01:18 AM
could not find mime type application/octet-stream WhiteTornado Fedora 7 04-12-2006 12:52 PM
mime type application/octet-stream SLP SUSE / openSUSE 1 03-20-2006 05:29 PM
Could not find mime type - application/octet-stream EuroJovi Linux - Software 4 01-26-2006 01:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration