LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-19-2014, 01:45 PM   #1
ejspeiro
Member
 
Registered: Feb 2011
Distribution: Ubuntu 14.04 LTS (Trusty Tahr)
Posts: 203

Rep: Reputation: 26
Unhappy Undesired and unrequested change on windows appearance on Ubuntu 14.04


Dear all,

I was updating my applications on my Ubuntu 14.04, when I installed Jovie, the KDE Text-to-Speech plug in.

I then uninstalled it.

I do not know if this is related but after I restarted, my KDE applications such as Kate, and even Firefox, are showing a strange look and feel:

See attached image.

What caused this? How can I revert this? I personally do not like that look and feel...

Thanks in advanced!

PS: The second attached image shows the look and feel I have always have, which is what I want
Attached Thumbnails
Click image for larger version

Name:	Screenshot%20from%202014-05-19%2013%3A40%3A53.png
Views:	9
Size:	103.9 KB
ID:	15536   Click image for larger version

Name:	Screenshot%20from%202014-05-19%2015%3A44%3A31.png
Views:	9
Size:	100.5 KB
ID:	15538  

Last edited by ejspeiro; 05-19-2014 at 03:48 PM. Reason: Adding comparison point
 
Old 05-19-2014, 03:34 PM   #2
ejspeiro
Member
 
Registered: Feb 2011
Distribution: Ubuntu 14.04 LTS (Trusty Tahr)
Posts: 203

Original Poster
Rep: Reputation: 26
Update

I have been trying different things. I think this behaviour is related to Compiz.

When I right-click on the Desktop, and I change the theme of Unity (I keep it in Ambiance, which is the default), it DOES NOT change right there... I have to log out! Say I want the Radiance theme... I select it, BUT I HAVE TO LOG OUT.

That is new.

When I log out, the look and feel of my KDE applications, as well as the look and feel of Firefox, go back to how they used to be!

If I go back to ambiance, then it stays the same, until I log in and out again.
 
Old 05-19-2014, 03:39 PM   #3
ejspeiro
Member
 
Registered: Feb 2011
Distribution: Ubuntu 14.04 LTS (Trusty Tahr)
Posts: 203

Original Poster
Rep: Reputation: 26
Update

I tried to restart both Unity and Compiz, as in here:

Code:
#!/bin/bash
sudo dconf reset -f /org/compiz/
setsid unity
unity --reset icons
And I got nothing...
 
Old 05-19-2014, 03:48 PM   #4
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 8,315
Blog Entries: 13

Rep: Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703
Is your problem that the windows are always maximized with no borders?

There are various solutions depending whether you have Unity-2d or Unity-3d.

This is one of the solutions I've found which worked for me using Unity-2d:

http://askubuntu.com/questions/40571...hing-maximized

There's a config utility; however I do not see the options they talk about, one answer by ldrn states:
Quote:
To fix this with Unity 2d, do this on the command line:

Code:
gconftool -s /apps/metacity/general/auto_maximize_windows -t bool false
Or, launch gconf-editor and change that key to false.

This annoyed the heck out of me, too. The fix is different for unity 2d than for 3d unity,
And that one did work for me.

I found that determining what you're running, 2d or 3d; or even if you're running it at all is a good first step and then searching for solutions with that specific string helps.

Last edited by rtmistler; 05-19-2014 at 03:50 PM.
 
Old 05-19-2014, 03:54 PM   #5
ejspeiro
Member
 
Registered: Feb 2011
Distribution: Ubuntu 14.04 LTS (Trusty Tahr)
Posts: 203

Original Poster
Rep: Reputation: 26
Quote:
Originally Posted by rtmistler View Post
Is your problem that the windows are always maximized with no borders?
Nop My problem is that, suddenly, my KDE applications, such as Kate, KBibTex and even Firefox, adopted a different look and feel.

Please see the first post, to see the difference.

Thanks.
 
Old 05-24-2014, 07:32 PM   #6
ejspeiro
Member
 
Registered: Feb 2011
Distribution: Ubuntu 14.04 LTS (Trusty Tahr)
Posts: 203

Original Poster
Rep: Reputation: 26
Well,

It solved... itself :S

I ran this:

Code:
#!/bin/bash
sudo dconf reset -f /org/compiz/
setsid unity
unity --reset icons
And I also installed the old GNOME, ran a session on it, and when I got back to Unity, it was fixed...

I'm calling this one as solved.

Thanks!
 
  


Reply

Tags
kde, ubuntu 14.04, unity


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I change the appearance of my Windows in Gnome? Ian D Fedora 1 02-15-2013 01:15 AM
want to change appearance of terminal in genome ubuntu 9.10 linux.ab Linux - Newbie 1 04-17-2010 01:38 AM
Change appearance of GRUB Norab Linux - Software 8 08-29-2005 08:09 PM
Way to change tooltips appearance? z-vet Linux - General 1 12-27-2004 05:14 AM
change nautilus appearance andymadigan Linux - Software 3 08-08-2004 04:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration